Land Rover and Range Rover Forum banner
1 - 3 of 3 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
Hey Everyone!

So I had a steering problem with my 94 Classic LWB, where it was building up pressure and throwing it all over my engine compartment. All the hoses were fine, but I had way too much play in the steering. Turned out to be the steering box. I replaced it with one from my 92 Classic SWB (my parts supply, I also have a complete 93 SWB as well but I'm trying to rebuild that one as well and not rob parts from it). Totally worked fine for a month (360 miles). Then all of a sudden I started hearing a gear meshing type of sound. I figured that it may be from my hubs or differentials needing EP90 or One Shot. When I got home, I parked the Classic and opened up her Bonnet to find ATF from the power steering area thrown around once more. (Still doesn't mean that my diffs and hubs don't need any lube!), however, I am at a loss since I cannot pinpoint where the ATF is spewing from other than the top of the reservoir around the cap. It must be building up pressure somewhere. I did start to notice more play in the steering again.

My question is: Is this a sign/indication of a steering pump problem? Air in the PS lines? Or something else? I looked in the forums, but I could not locate anything specific to my malady.:dunno:
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #3 ·
As an ancestral Land Rover owner - I have long since discarded my pride (I have been a humbled Land Rover Owner since 1995 and have owned and appreciated a 96' 4.6 HSE, a 4.6 Westminster, 92' 3.9 SWB Classic, 93' 3.9 SWB Classic and my latest - 94' LWB 4.2 Classic) I will look once again for any leaks. Ugh, "Why do I continually subject myself to the woes of Land Rover ownership.........because they are worth it!!!".
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #4 ·
i checked the hoses and found the problem!

I have to thank "LAclassic" very much! I re-checked the hoses and was still baffled. Couldn't find a leak - until I decided to cut back the ends of the hoses to put it back together. I noticed that the reinforcing thread fibers of the power steering hose was saturated with ATF fluid. I cut back the hose about 6cm before the fibers started to appear dry. Closely inspecting the length of hose, it appears that the hose had an internal leak into the fibers (looked like a tiny slice from the inside that only went to the depth of the interwoven fibers) and then oozed out of the ends of the hose after the hose clamp, where the fibers were exposed closest to the reservoir! Sneaky leak! I guess I was further confused since the ATF was banking off the bottom of the reservoir and shooting in a weird direction. With this discovery, thanks to "LAclassic", it turns out that I replaced the old steering box for nothing.......well actually, it was a great learning event! Now onto the next problem! (A/C air is blowing in every direction other than through the vents!). Gotta get under the dash and reconnect a bunch of vent hoses!! What's with RRC's and hoses!?? I think it may be the heat of Las Vegas!:cool:
 
1 - 3 of 3 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top