Land Rover and Range Rover Forum banner
1 - 3 of 3 Posts

·
Sand fan!!
Joined
·
39 Posts
Discussion Starter · #1 ·
Greeting,

I,ve brought a Land Rover 4.6 GEMS engine (Black square top) which it was imported from Japan, to be installed in a 110 Defender.

on the floor the engine starts Ok connecting the 4 ground and 2 +ve power.

after fixing the engine to the car ... it dose not start at all (no Spark). the fuel pump relay and main supply power relays works fine as it should be triggered form ECU.

OBD Connection on the tester show no connection with ECU using land rover specific scan. on general OBD 1.44 it could read.


the number on the EPROM inside ECU is 9608 (Tune Number).

1) What you think is the problem ?
2) Can I remove the security immobilizer?
3) how much it will cost?

BR,
:crying
 

·
Registered
Joined
·
4,797 Posts
Greeting,

I,ve brought a Land Rover 4.6 GEMS engine (Black square top) which it was imported from Japan, to be installed in a 110 Defender.

on the floor the engine starts Ok connecting the 4 ground and 2 +ve power.

after fixing the engine to the car ... it dose not start at all (no Spark). the fuel pump relay and main supply power relays works fine as it should be triggered form ECU.

OBD Connection on the tester show no connection with ECU using land rover specific scan. on general OBD 1.44 it could read.


the number on the EPROM inside ECU is 9608 (Tune Number).

1) What you think is the problem ?
2) Can I remove the security immobilizer?
3) how much it will cost?

BR,
:crying
What are you doing differently in the body of the vehicle versus on the floor?

I am knowlegable on disabling this function but am hesitant to do so online.
 
1 - 3 of 3 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top