Land Rover and Range Rover Forum banner
1 - 3 of 3 Posts

· Registered
Joined
·
31 Posts
Discussion Starter · #1 ·
Hello all, It's a 92RRC County LSE, I took out the malfunctioning LR head unit and have been 'attempting' to install an aftermarket radio. I have done many of these in the past, though none on a rover, so I just started cutting and splicing wires as I've done in the past.

I have power and memory to the radio, but no sound anywhere. I was told that there is a factory sub somewhere and the power 'on' wire for that is the yellow/purple, so I put the yellow/purple wire from the rover to the 'amp on' 'blue' wire from my deck, but still nothing, I've tried swapping speaker wires and everything.

Obviously, I'm missing something. Does anyone know where the fuses for the factory sub(s) are located, and/or where the sub(s) themselves are located? Has anyone had this problem? I'm trying my best to comprehend wiring diagrams, but I'm not that saavy with that stuff! :eek:

So if anyone could help and tell me any of that or if you've done one and remember what wires to hook where, I'd greatly appreciate it. I love driving my rover, but I do need music!! :buttrock: and I don't want to spend $180-$200 bucks at the stereo shop to have them do it if at all possible.

THANKS!!!!!! -Mike
 

· Premium Member
Joined
·
10,167 Posts
Sounds right..Are you sure the radio is working!!! I have a sony deck and it went right in no probs!!!
:dunno:
 

· Underwater hockey is no dumber than any other spor
Joined
·
259 Posts
I had the same problem on my 91 RR. Apparently the output from most modern aftermarket radios are not compatible w/ the stock amps in the RR Classic. To solve mine, I had to wire directly to all the speakers from the back of my new radio. It was a bit of a PITA, but not too hard. I wasn't that impressed w/ the volume after that job (and I don't blast my radio or anything), so I bought a 5-channel SONY amp from Crutchfield (only like $200 in their scratch and dent bin), and wired that up. Sounds great now!
 
1 - 3 of 3 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top