Land Rover and Range Rover Forum banner
1 - 2 of 2 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
Hi, new to the forum but from the post i have read there is alot of troubled rovers. I have a non running 93 that has been a pain in the butt for over a year, doing the same as alot of the post. It might run fine for awhile then it will stall out like it is not getting any fuel. It might take 4-5 tries to start and once it is started run awhile then do it again. It might not start at all. Have had it towed to landrover dealership and it started right up. They put it on computer and said that it wouldn't heat up enough for the computer to read due to intake manifold gasket leak. Wanted $1600 to fix that so I passed. They replaced fuel filter, checked fuel pump said that was ok and it has run fine for last 4 months but started again. I have replaced fuel filter but this time it still won't start. Have checked spark from coil and that seems strong. It has 130,000 miles on it and has had a tune up right after I bought it a year ago and has probably had 5000 miles put on it during the last year. It also stuck in hi-range, will not go into low. Dealership said that cost about $600 to fix. Any info would be appreciated. When it does run it idles fine and has good pick up on accelleration and starts first time every time.
 
1 - 2 of 2 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top