Land Rover and Range Rover Forum banner
1 - 2 of 2 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
I see others have posted similar msgs for different models and years. I'm in the middle of upgrading the factory radio. I have purchased a standard kenwood and trying to match wires. I pulled out my Haynes Manual and found a wiring diagram, but many of the wires don't match. I began testing the red wires with a multi meter to see what was providing the battery power and what was providing the ignition. Haven't found any wires that produce more that 1 Volt. The radio was working before I took it out, so I know something was giving it power. I'm checking the fuse next. Anyone had similar problems are know of better wiring info?
 

·
Registered
Joined
·
146 Posts
Forget using a multimeter and get yourself a test lamp

If I can remember the pink wire is the power and red is the memory

You should have the same dash in yours as I have in my 98 model and if so when you go from a standard to aftermarket fit you don't use all the wires that are there ( I think 2 of them are for security on the old unit )

With the key turned off start testing your wires Only 1 should light up and that will be your memory wire , the turn on your key to acc and now 2 should light up took me about 1.5hours to install mine.

I found too that the wiring diagram in the manual is usless as the wires for my speakers were a different colour to what the manual said


Adam :beer:
 
1 - 2 of 2 Posts
Top