Land Rover and Range Rover Forum banner
1 - 6 of 6 Posts

· Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
Hello everyone, I have a 1995 Range Rover Classic LWB with the soft dash. A while back, the battery holder came loose and contacted the positive post on the battery. I have since installed a new battery, but now the following warning lights stay illuminated; SRS, ABS, BATTERY. It also seems that it is not taking a charge when I run the engine.

Could you please help me to figure out what is causing this? I have checked most of the fuses, but am not really familiar with the electrical systems in these.

I love my rovers, as I have both a 1994 LWB County and a 1995 LWB. Any help would be great. Please start out with the obvious things to check, and go up from there.

Thank you very much.

Marc
 

· Registered
Joined
·
52 Posts
I am sure there is a way. I think the tachometer runs of the alternator, is it working? Without proper equipment it may not be accurate. One indicator is that headlights will get brighter, when higher RPM. I usually take it to the auto parts store, they will check it free.
Someone may chime in on this.
 

· 1993 range rover lwb - Roman Bronze
Joined
·
533 Posts
To check to see if your alternator is failing, try this: open hood, start truck, go to the battery and take off just the negative connection..... If the truck still idles then it's not your alternator....if it dies instantly then it's your alternator.....hope that helps
 
1 - 6 of 6 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top