Land Rover and Range Rover Forum banner
1 - 3 of 3 Posts

· Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
So I was on my way to the dump, "The Tank", my '99 Discovery II with 178k miles was running fine. All of a sudden, the motor stalls (no limp mode, just dies). The dashboard lit up like a Christmas tree (Merry Christmas, Bah!) The *M* and *S* lights were blinking together. No start, engine cranking fine. After getting a flatbed to bring me home, I read three codes with my generic ODBII reader:
P1884 Can Message WFPDK (DKI invallid Ffh)
P1562 Battery supply
P1843 Can timeout monitoring

ALSO, the fuel pump relay makes a clicking noise like mad (random timing) for about a minute after the key is shut off. WTH?:help

After researching online, I've come up with three ideas
1: The XYZ switch. Water in the switch?
2: The battery grounds near the transmission computer.
3: The fuel pump (Fuel light is on, tank is low).

Any other ideas? Other possibilities?

Thanks,
Keith in NH
 

· Premium Member
Joined
·
16,548 Posts
First, don't worry about the 1884, it has 8 different meanings but it usually just tags along because of one of the other codes.
I would suggest you take you battery out and give it a 2 hour then try and start it.
If it starts, and you have an OHM meter check the output from the alternator which has to be between 13.6 and 14.4 volts
then get back to use.
 

· Registered
Joined
·
2 Posts
Discussion Starter · #3 · (Edited)
Thanks for the reply, Mike.

I tried the battery trick. No change. I pulled a plug wire and put a spare plug on it. Grounding the wire on the frame and cranking the engine, no spark. I changed the CPS about a year and a half ago (I've driven less than 10k miles on the new sensor) so I don't think that's the issue.

I decided, since the vehicle won't start, look at how behaves with the key in the "run" position. When the key is put into the run position, vehicle in park, no flashing lights. Moving the shifter out of park caused lights to flash (M&S together, etc). I decided to go after the XYZ switch.

I've got the switch out, and it looks nasty-oily and dirty, so it looks like that might be the problem. I'm going to open it up and try the cleaning/rebuild method that I've seen on some forum posts.

In the process of removing the switch, I've run into another problem: The nut was rusted to the transmission shift shaft, even with the PB blaster and (tried to) gently turning the 13mm nut, the tip of the shift shaft broke off.:eek:

If I drop the transmission pan, how hard is it to change this shaft? I don't see a good way to hold the shift arm onto the shift shaft without the nut holding the arm on to the shift shaft. Ugh.

Thanks
Keith

UPDATE:
I took apart my XYZ switch, the cam wheel was cracked in three places and it must have slipped on the shaft when I tried to shift into gear. So I'm pretty sure I found the problem.

- Keith
 
1 - 3 of 3 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top