Land Rover and Range Rover Forum banner
1 - 6 of 6 Posts

·
Registered
Joined
·
229 Posts
Discussion Starter · #1 ·
well it looks like that i need a new ABS sensor for my 96 disco, passenger front...pulled it out and ran the meter on it and it didnt give me a resistance reading, the driver side read about 1k ohm's which i believe is in good operating range...is there anything else i should look into before replacing the sensor...i pulled the sensor completely out and checked it over very closely and its all ok, im just thinking that i need a new one, right?

btw if anyone has one for sale let me know!

thanks
Spencer :rellye
 

·
Former LR tech, Albany NY
Joined
·
2,437 Posts
abs sensors wont work without turning. Then you have to add voltage to see if its good or not.

Basically you need an oscilloscope to really see the output from the sensor.

Other then that you need to drive and pay attention to the individual wheel speed sensor outputs. basically the comp will tell you what the speed the senso r is going.
 

·
Registered
Joined
·
229 Posts
Discussion Starter · #6 ·
beezel said:
abs sensors wont work without turning. Then you have to add voltage to see if its good or not.

Basically you need an oscilloscope to really see the output from the sensor.

Other then that you need to drive and pay attention to the individual wheel speed sensor outputs. basically the comp will tell you what the speed the senso r is going.
well i tested the other sensors and i get about 1k ohms...this one i do not get any...i do believe that is one of the ways to test them...
 
1 - 6 of 6 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top