Land Rover and Range Rover Forum banner

1 - 2 of 2 Posts

·
Registered
Joined
·
10 Posts
Discussion Starter #1
the blower acted like it shorted out a couple times, you know stop then 5 min later start back up. Now it just quit all together, i have checked the blower motor its fine, ran checks on the relays and even purchased a new blower relay. Still doesn't work! AC compressor is on everything runs good just no blower for AC or Heat. getting power to the blower motor just not full 12 volts. I wonder if it could be a ground, has anyone else had a similar problem Also im assuming i found the blower relay, where mine is i think there is two, one for blower and one for switching the vents and so on. Rave shows very little on this and its English so its showing it backwards.
 

·
Registered
Joined
·
21 Posts
the blower acted like it shorted out a couple times, you know stop then 5 min later start back up. Now it just quit all together, i have checked the blower motor its fine, ran checks on the relays and even purchased a new blower relay. Still doesn't work! AC compressor is on everything runs good just no blower for AC or Heat. getting power to the blower motor just not full 12 volts. I wonder if it could be a ground, has anyone else had a similar problem Also im assuming i found the blower relay, where mine is i think there is two, one for blower and one for switching the vents and so on. Rave shows very little on this and its English so its showing it backwards.
There are 2 plastic conectors that are pron to failure one is the conector that plugs directly to the blower itself, and there is a yellow one just before this plug, the plastic on this conectors tend to burn and cause electric failure, it has happened to me on this 2.
 
1 - 2 of 2 Posts
Top