Land Rover and Range Rover Forum banner
1 - 3 of 3 Posts

· Registered
Joined
·
8 Posts
Discussion Starter · #1 ·
Does anyone have a fix for this? I disconnected battery to do some repair work and now the radio does not work? It comes on for 5 sec when u turn key and the shuts off. On the screen it says phone code but the 06 lr3 does not have integrated phone option because it's a 4.0 base model. I tried pulling radio fuses to reset but that did nothing. Should I do a hard reset that I read about on this forum? Is that safe to do? I don't like the idea of putting a wire to the neg and positive terminals. Thanks to anyone who can help me! The radio worked fine before disconnecting battery but I was playing with both footwell wire harnesses during my repair so maybe that has something to do with phone code being displayed on radio? None of the buttons work at all to even punch in a phone code if I had one. Thanks again for anyone's help! I'm stuck
 
1 - 3 of 3 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top