Land Rover and Range Rover Forum banner
1 - 6 of 6 Posts

· Registered
Joined
·
64 Posts
Discussion Starter · #1 ·
Well I went off road today and I had to put it into low gear. but when I put it in low an alarm is going off. I think it was doing it in neutral also any idea whats going on?
 

· Wheeler
Joined
·
1,837 Posts
Are you certain you had it fully engaged in low-range? Sometimes you have to give it a good old push,,especially if prior owner never had low range engaged. Did you do the trail in low with the alarm on, or run it in high range? Is this a manual or auto?---if auto, when you engaged low range did you put the gear shifter in drive or select a lower gear?
 

· Registered
Joined
·
64 Posts
Discussion Starter · #3 ·
I am pretty sure.. But I didnt leave in for too long, I took it out put it back in hi then back in low a couple times and same thing. Like it wasnt on for a few mins then it just came on.

Once it was on I didnt drive to long like that. I put it back into HI again.

Its an auto and when I put it in low or hi I stop push and hold foot brake put it in neutral pull up e-brake then I switch it to hi or low.

I didnt have much time to mess around or look at but I could tomorrow if it is just something I might have overlooked or something. I never heard the alarm before though so just got a little worried.
 

· Wheeler
Joined
·
1,837 Posts
I'm not 100% certain oln a D1, perhaps others could comment. My gut feeling would be that it wasn't fully engaged in low. Don't take this as an insult,,, the transfer cases can 'stick' if not engaged for long period of time. This also happens w/ the CLD. It could be a blown solenoid on the t-case, but in this case you would clearly not be able to engage low range,, ie: you would know you were not fully engaged. Did your 'check engine' light come on, or just the audible alarm?
 

· Registered
Joined
·
64 Posts
Discussion Starter · #5 ·
well it did engage in low well at least I could drive in it. I will try it again tomorrow to make sure I had it in all the way. no lights came on but then again I dont even know if all the lights work. Since none comes on when its in low.
 
1 - 6 of 6 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top