Land Rover and Range Rover Forum banner
1 - 9 of 9 Posts

·
Registered
Joined
·
10 Posts
Discussion Starter · #1 ·
Installed 3 inch lift and now the ride height light is on and constant beep going off like it is trying to let air out of the rear air bags that are now coils. Can I just unplug the two ride height sensors? Or what do I need to do to end this pain....help please
 

·
Administrator
Joined
·
2,423 Posts
Have you reconfigured the computer from air suspension to coil suspension?
 

·
Registered
Joined
·
10 Posts
Discussion Starter · #3 · (Edited)
So heres what I did...

I read on another post if you cut the yellow/white blue/orange and black/white wire coming out of the second plug from the end facing you out of the dash, on the slabs ecu it will stop the beeping. So i did. And id did not stop. So I disconnected the battery and waited a bit, reconnected and drove...and YAY no more beep. But heres the catch. Now my radio wont power on. But it worked fine before I disconnected the battery after I cut the wires...really got me stumped.

(btw i cut the wires because there is no shop I can find that will reprogram the ecu near me and the beeping was enraging me, Berglund Land Rover here in Roanoke has the wrong computer, supposedly you need to be running windows xp... was what I was told.)

So far I checked all the fuses and the wiring harness on the head unit just to be sure, but the only fix I can think of to get radio back is to have the ecu reprogrammed and reconnect those wires?
 

·
Registered
Joined
·
1,166 Posts
Never heard of the "cutting wires" solution. I personally would be leary of cutting that many. Everything is so interlaced with these trucks, it would not be outside the realm of possibilty that the radio could be affected as well.
 

·
Administrator
Joined
·
2,423 Posts
Many professional scan tools can reconfigure.
We have a Autel at work that is capable.
Maybe ask around local shops about a good euro scan tool after you reconnect, solder and seal all the wires you butchered��
Hard to believe a dealer can't do it. It's really straightforward
 

·
Administrator
Joined
·
2,423 Posts
Afterthought
You may not be able to reconfigure it ifyou have3 amigos happening
 

·
Premium Member
Joined
·
1,738 Posts
So heres what I did...

I read on another post if you cut the yellow/white blue/orange and black/white wire coming out of the second plug from the end facing
those wires are for the two air supply valves and the exhaust valve in the compressor housing, cutting them is the same like if you unplug the valve's plugs at the compressor... dont believe everything you read before you double check, you can let those wires cut cos they have no effect while it's on coils but nothing to do with the audible warning and radio whatsoever.... i have a strong feeling that the beeping will come back soon, the radio thing is coincidental, usually the radio needs an activation code after the battery was disconnected
 

·
Registered
Joined
·
10 Posts
Discussion Starter · #9 ·
Been driving it for a week now, beeping has not returned. Radio still playing dead, (aftermarket head unit...forgot to mention) haven't had a chance to play with it, will this weekend. Eric at lucky8 put me in touch with a guy nearby that can reprogram my ecu. Guess I will do that just to avoid it ever coming back in the future.
 
1 - 9 of 9 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top