Land Rover and Range Rover Forum banner
1 - 11 of 11 Posts

·
Registered
Joined
·
55 Posts
Discussion Starter · #1 ·
When I started her up this morning and let her idle, I heard a squealing sound coming from under the hood. I stepped on the gas pedal and the sound went away. On my ride home I noticed the interior tach lights and radio lights dim, then go back to normal after a minute or two. I have a feeling it may be the alternator on it's way out.....

Has anyone out there experienced similar symptoms?
 

·
Registered
Joined
·
2 Posts
NJRover said:
When I started her up this morning and let her idle, I heard a squealing sound coming from under the hood. I stepped on the gas pedal and the sound went away. On my ride home I noticed the interior tach lights and radio lights dim, then go back to normal after a minute or two. I have a feeling it may be the alternator on it's way out.....

Has anyone out there experienced similar symptoms?
I have the same squeal. And it goes away when I hit the gas. My mechanic could not find the problem and it still squeals. No problem with the lights, but my new battery suddenly went dead. I replaced the battery and no more problems.Alternator is good. But, that squeal is still there. I want to know, too.
 

·
Registered
Joined
·
55 Posts
Discussion Starter · #8 ·
antiqlove said:
I have the same squeal. And it goes away when I hit the gas. My mechanic could not find the problem and it still squeals. No problem with the lights, but my new battery suddenly went dead. I replaced the battery and no more problems.Alternator is good. But, that squeal is still there. I want to know, too.

Went in to take a look and can't find anywhere to tighten the belt. It continues to squeal until I step on the gas. I can live with it as long as it's not my alternator. If it is my alternator, I bought an extended warranty through Warranties 4 Wheels ( I see they are now advertising on the forum) My alternator is covered if it should go bad so I'm not overly concerned, just don't want to get stranded and have to get towed back. The sound is intriguing and would love to know what the culprit is.
 

·
Premium Member
Joined
·
10,236 Posts
NJRover said:
Went in to take a look and can't find anywhere to tighten the belt. It continues to squeal until I step on the gas. I can live with it as long as it's not my alternator. If it is my alternator, I bought an extended warranty through Warranties 4 Wheels ( I see they are now advertising on the forum) My alternator is covered if it should go bad so I'm not overly concerned, just don't want to get stranded and have to get towed back. The sound is intriguing and would love to know what the culprit is.

My guess is the belt needs replaced or the tensioner is getting worn....Are you haveing any other problems with it?
 
1 - 11 of 11 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top