Land Rover and Range Rover Forum banner
1 - 2 of 2 Posts

·
Registered
Range Rover HSE - L322 - 2004 - 3.0
Joined
·
3 Posts
Discussion Starter · #1 ·
A little over a month and a half ago I changed brake pads and discs on my Range Rover L322. Within a few days of the change the brake pad alert has come on, and since then it has stayed on with short periods in which it has gone off but has never lasted more than a day. Obviously the mechanic who has made the change has already taken it and he tells me that he has checked everything, pads, sensors etc ... and he does not find the reason why this light does not go off. He tells me that he would have to check the connections from the control panel that is in the back but that it would take many hours of manpower so before deciding to do it I prefer to check here if something similar has happened to someone. Another option would be to take it to the official Land Rover workshop in my area to see if it is just a system reset what is needed ...
Thanks
 

·
Registered
Joined
·
1,936 Posts
I do not know the RR; I have a Disco. But try the simple things first. Take the cap off the master cylinder and check the brake fluid level. If there is a float, give it a wiggle in case it is stuck. If there is a reset on the master cylinder, reset it. Set and release the parking brake a few times. There is just a chance something simple like this is the problem.

And good luck. Let us know when it is finally resolved; the solution will help the other forum members.
 
1 - 2 of 2 Posts
Top