Land Rover and Range Rover Forum banner
1 - 4 of 4 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter · #1 ·
Hi all!
Just changed the battery in my 99 Disco II. This is the second time the battery had been changed (I know, I have had her since 99).
The problem I have is that she seems to be immoblized or thinks maybe she is getting stolen or something.
FACTS: The only way to unlock/lock is by putting the key in the drivers door. I open the door and usually the interior lights come on - nothing. She won't crank, she still in park won't go into any other gear. I turn the key to crank her and the dashbnaord does as normal with chimes and lights etc. But won;t crank.

I called LR roadside assistance and they talked me through the deal with the key in d/s door turn unlocking-pausing at center- then locking do this 3 times then with the key in the ignition for 10 seconds start the rover. Nothing works. I did everything that owners manual suggested too.

All i did was replace the battery. She is a 199 LR Disco series II SE7 w/out ACE. 88,000 miles. I live 4 hours away from the nearest LR dealer. No one works on Rover where I live Albany, GA.

Please help with any ideas, suggestions!
 

·
Premium Member
Joined
·
16,594 Posts
Have you verified that the new battery is good, do you have 13.8 to 14.4 volts between the posts?
I have a 99 D II changed out the battry once, put in duals, but never had any problem other then resetting the alarm with the key in the dooor trick that Rover mentioned to you.
Does anything happen when the key is turned, starter clicking, headlights dimming, that sort of thing?
Wish I had a better idea that might help you but I am lost on this one.
Let us know what you find.
Mike J.
 

·
Super Moderator
Joined
·
828 Posts
Bad ground cable??

Just taking a stab in the dark on this one.
 
1 - 4 of 4 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top