Land Rover and Range Rover Forum banner
1 - 4 of 4 Posts

·
Registered
Joined
·
9 Posts
Discussion Starter · #1 ·
So I have a 2000 Disco
170K miles
Has ace
converted from air to coil
Newer optima battery and alternator reads just under 14V

So I had a little fun in the rain and mud tonight and now Im getting all kinds of weird issues.

1. Ace error light comes on after driving for 1-2 minutes (goes off after system check upon start up)

2. Reverse lights are Illuminated slightly even when car is not in reverse

3. SLABS computer is illuminating the hill decent light and Giving a fault that says something to the effect of "improbable Gear selection"

I have tried disconnecting battery for a while and nothing.
I have also checked out all the Computers (Slabs, ecu, bcd, trans) There is not a drop of water anywhere. They are so dry that there is a layer of thick dust just building up them.

If anyone can shed some light on whats going on i would really appreciate it
 

·
Registered
Joined
·
52 Posts
How much fun? ( how deep was the water)
 

·
Registered
Joined
·
4,794 Posts
Check transmission. There is an electric box on side, might have gotten wet. Will need to dry out.
It is not an "Electric box" it is the transmission position switch-often referred to as the XYZ switch.

If you did not have water in the cabin (in which case, all bets are off) your most likely issue is with either water in the XYZ switch, or water ingress to the wiring harness at the connector on the side of the transmission.

The other typical problem leading to transmission issues on DIIs is charging system related.
 
1 - 4 of 4 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top