Land Rover and Range Rover Forum banner
1 - 10 of 10 Posts

· Registered
Joined
·
47 Posts
Discussion Starter · #1 ·
I notice a faint coolant smell from the radiator (passengers side) while the engine is warm. No loss in coolant, always in the middle of the two lines on the expansion tank (when cool), never runs hot. I checked the hoses going to and from the radiator, no signs of leaking. Can the radiator have a slight crack and be leaking? I'm stumped. Any thoughts? I plan on driving a 12hour trip this summer for vacation. Any help would be greatly appreciated!
 

· Registered
Joined
·
249 Posts
I also have a slight coolant smell in the engine compartment. I was told this was normal on one of the forums...

I have just replaced my coolant expansion tank because I was getting a "low coolant" warning message... I have noticed that I still have the smell, but I am also not losing any coolant.
 

· Registered
Joined
·
47 Posts
Discussion Starter · #3 ·
Yes, very strange. The smell is strongest at the top corner passenger side of the radiator. Again, no signs of leaks around the hose connections.
It looks like the sides of the radiator are plastic?! Could this be cracked?
 

· Registered
Joined
·
249 Posts
The top corner of the radiator on the passenger side has both the overflow and the upper radiator hose connector... Did you check both for leaks? Most radiators nowadays have plastic sides... Annoying.. I have the procedure to remove the radiator if you would like it.
 

· Registered
Joined
·
525 Posts
The plastic crossover the thermostat is mounted in could also be a culprit. View the front of the engine for white burned off coolant. Replace it as an assembly.
 

· Registered
Joined
·
525 Posts
The housing part that the thermostat mounts in also is due to cracking. That's why it's best to change the whole assembly. I've had two crack since I've had the vehicle.
 

· Registered
Joined
·
7 Posts
before buying my 06 Lr3 i test drove numerous other RR's...all "used" and they all had that coolant smell. It was never present in the cabin via the HVAC system, but pop the hood and stick your nose around in the engine bay and you can smell it. Never any visible signs of fluid though.

My 87.5K mile Lr3 had the smell as well...very faint, but there. Bought it anyway.

just one more data point.
 
1 - 10 of 10 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top