Land Rover and Range Rover Forum banner
1 - 6 of 6 Posts

·
Registered
Joined
·
391 Posts
Discussion Starter · #1 ·
my 1997 disco 1 cruise control doesn't work...and i am either gonna live without it...or fix it myself...any help at all is greatly appreciated...as i know noting about it
 

·
Registered
Joined
·
43 Posts
first look under the hood up near the intake manifold, right where the throttle cable goes, look and you will see a rubber bulb with a cabel comming out of it, this is the vaccum bulb that holds the throttle open, squeeze this and listen for air leaking, track down the leaking air, in most cases it will be at a T connection just a few inces away at the fire wall, if broken fix, usally just reconnect the hose [they split] if all vaccum hoses are good check connections at the vaccume pump, this is found under a plate where the bottle jack is stored, a little tuff to get in there but look thru the access hole and you will see the little electric pump, from there also check your fuses if you have not already and finally check your master switch on the dash...... but 90% of the time it just a vaccum leak -Andy
 

·
Registered
Joined
·
391 Posts
Discussion Starter · #3 ·
just a simple vaacum leak could cause it to not work at all?
 

·
Registered
Joined
·
43 Posts
YUP, the little pump up front is a small vaccum, if there is a leak in THIS system them no pull on the bulb to hold open the butterfly valve in the throttle body, now you can have a vaccume leak somewhere else in the rover but the CC is its own system.... so isolate and you will find your problem..... i hope -Andy
 
1 - 6 of 6 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top