Land Rover and Range Rover Forum banner

1 - 5 of 5 Posts

·
"Faxify this thang, you Dumsumbitch!"
Joined
·
5 Posts
Discussion Starter #1
I'm new to "rovers, but not to mechanical issues...

When above 35 MPH, if I let off of the accelerator, I get a very slight thump. Something I'm used to with older AWD trucks, My Landcruiser had it...
But the last week or so, I've noticed a new noise after that thump, a rattling coming from the rear. This happens only when coasting above 35 MPH or coasting downhill.
What is it?
 

·
Premium Member
Joined
·
16,594 Posts
So, have you crawled under the truck and done a full visual of the entire drive train? Check the front shaft and make sure that all 3 u-joints each have a grease fitting.
What year is the truck, how many miles on it?
 

·
"Faxify this thang, you Dumsumbitch!"
Joined
·
5 Posts
Discussion Starter #3
Its a 2003, 135,xxx miles... I just rolled under there, and it doesnt look dry. I just got the truck a few months ago, so i cant really say exactly if and when it was greasesd.
So, if it sounds like the noise is coming from the rear, it might be the front?
Another thing i noticed on my way home, is a low whine is now present.

Sent from AutoGuide.com Free App
 

·
Premium Member
Joined
·
16,594 Posts
Sounds like you are going to need to tackle this stuff real soon. If you want, send me your number and lest walk you thru what to do/fix.
 

·
"Faxify this thang, you Dumsumbitch!"
Joined
·
5 Posts
Discussion Starter #5
Im a fairly competent mechanic, I've built and maintained many different types of machines, just need to be pointed in the right direction.
Everything I know, tells me it's the rear end.
I know Jeeps and Landcruisers, but my Discovery is completely new to me.

Sent from AutoGuide.com Free App
 
1 - 5 of 5 Posts
Top