Land Rover and Range Rover Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
Done all the usual checks all OK suspected injector wiring loom oil leak down to ECU. found very slight trace of oil. removed injector harness completly cleaned out multi plug of oil contamination. measured resistance accross injector coils all range from 1.4 to 1.7 Kohms. Removed red plug off ecu did same resistance test all identical. Replaced same tries to start then just continues cranking. DELPI Diagnostic code shows ABS, AIR Con Transmission faults. and PEAK CHARGE INo 5 short. Removed injector no 5 plug engine starts and runs on 4 cylinders. DELPHI NO FAULT Codes SO thought replace no 5 injector plug wont start.? HELP Please. Can injector 5 still caus this even with resistance values seem fine,
AUTODATA spec gives value of 1 Kohm at RED ECU plug disconected for all injectors.

I disconect injector wire pin 1 red plug ECU engine starts on 4 cylinders OK
Does anyone have any advise waiting in HOPE.
Regards Rob
 

·
Registered
Joined
·
12 Posts
Had this exact problem on an 18L Volvo generator engine. We replaced harnesses(no change), replaced injectors (no change) replaced ecu (everything better).
My educated guess would be either there is a short in the injector coil or a fault in the ecu.
I am not a land Rover expert by any means.
Have you tried disconnecting say inj #3 and trying to run that way?
When I did the Volvo, it would run well on 5 cylinders just not all 6. Did not matter what inj was unplugged.

Scott

Sent from my BBB100-1 using Tapatalk
 

·
Registered
Joined
·
3 Posts
Discussion Starter #3
Hi thanks for advise when I reconnect no 5 injector wnilst its running it will stop dead.. It will not start on disconnecting any other injector if no 5 is still connected. I am going to swap injector 5 and 1 to see if problem moves to no 1. How do you tell which ECU you have.

Cheers for your response.

Rob.
 

·
Registered
Joined
·
3 Posts
Discussion Starter #5
10P only on disconecting no5 will it start if I reconect no5 whillst running ECU shuts off and engine stops even on high revs.. swapped injector 1 and 5 problem still with no5 Cylinder. More advise please
 

·
Registered
Joined
·
12 Posts
Also, I would check the injector loom for breaks and follow back to the ecu. You may find a wire is rubbed through or shorted causing it to quit.

Sent from my BBB100-1 using Tapatalk
 

·
Registered
Joined
·
12 Posts
10P only on disconecting no5 will it start if I reconect no5 whillst running ECU shuts off and engine stops even on high revs.. swapped injector 1 and 5 problem still with no5 Cylinder. More advise please
Call the guys at "gentlemen of salvage" they are on the south cost of England.

Sent from my BBB100-1 using Tapatalk
 
1 - 8 of 8 Posts
Top