Land Rover and Range Rover Forum banner
1 - 6 of 6 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
I am a new Disco (1998) owner having driven the car for about a year to gain confidence before taking it deep off road, then my first trip!! :dunno: After 5 days through very rough terrain 4x4 only type stuff. The engine died during a bad corrigation section of road. We had tools and a electric manual but could not restart the car or find a fault, had spark, had fuel, had 12v on coil, engine turned over, but no ignition. Towed out by TDi for nearly 200 kms then low bed 550 kms to home.
Found that injector had no pulse but the fuel injector module is OK, engine starts occasionally for a few mins then dies again, has to be intermittent, am getting desperate to drive again but have lost total confidence in reliability as we cannot find any hard fault.

any ideas, or places to look, anyone had similar problems.
 

·
Registered
Joined
·
3 Posts
maybe a rusty fuel rail, or coil pack that is intermittant, also just a shot but have you changed the fuel filter since you bought it? if not then it it probably the fuel filter that has been there since new. For $14 i'd give the fuel filter a shot.

also hows your fuel pressure and fuel pump?
 

·
Registered
Joined
·
12 Posts
Two other possible options. If the engine runs and ticks over but dies when you try and drive check the in tank fuel pump. My 1991 V8i suffered from this and it was because of dirt in the fuel tank. It kept blocking the filter on the bottom of the fuel pump. You can get at the pump from the rear floor. Lift the carpets and sound deadening and you will find a circular plate. The fuel pump is underneath that. Failing that check out this link
LRE Forum

Ivan
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #5 ·
cobbers said:
I am a new Disco (1998) owner having driven the car for about a year to gain confidence before taking it deep off road, then my first trip!! :dunno: After 5 days through very rough terrain 4x4 only type stuff. The engine died during a bad corrigation section of road. We had tools and a electric manual but could not restart the car or find a fault, had spark, had fuel, had 12v on coil, engine turned over, but no ignition. Towed out by TDi for nearly 200 kms then low bed 550 kms to home.
Found that injector had no pulse but the fuel injector module is OK, engine starts occasionally for a few mins then dies again, has to be intermittent, am getting desperate to drive again but have lost total confidence in reliability as we cannot find any hard fault.

any ideas, or places to look, anyone had similar problems.
Hi guys thanks for the inputs so for, but all your ideas check out OK,

latest update, there is no pulse on the injectors but the injector control electronics box checks out fine, plenty of fuel pressure in the feed and fuel pump is fine. I am now looking for a detailed description of how the fuel injection system works and what sensors stop it from working, any new ideas??

Cobbers
 

·
Registered
Joined
·
454 Posts
cobbers said:
Hi guys thanks for the inputs so for, but all your ideas check out OK,

latest update, there is no pulse on the injectors but the injector control electronics box checks out fine, plenty of fuel pressure in the feed and fuel pump is fine. I am now looking for a detailed description of how the fuel injection system works and what sensors stop it from working, any new ideas??

Cobbers
problem in the wiring inbetween the module and the injector? Check the grounds.
 
1 - 6 of 6 Posts
Top