Land Rover and Range Rover Forum banner
1 - 3 of 3 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
Hi,

My wife has a 2000 V8 discovery which has a problem with I think the ABS sensors, sometimes whilst driving three warning lights come on on the dash, ABS - TC and inclinometer, after stopping and switching of the ignition, the light then don't come back on (until next time) when it happens all over again(this I've been told is not supposed to happen ?). Sometimes the warning lights come on and won't go out, we then have to take it to a specialist repair shop who resets the computer, the fault says front left or right wheel sensor. The garage says maybe changing the sensor would fix the intermittent problem but the cost of a sensor is huge if it won't fix the problem.

Any advice would be greatly appreciated.

Paul and Dot.
 

·
Registered
Joined
·
363 Posts
Aloha!

I get the same thing. All I do is move the ABS sensor around some. Then restart the truck and the lights go out. I will have them replaced when I bring the truck n for it's next oil change. As for the sensors. You might get them on line. It will save some money.
 

·
Registered
Joined
·
1,818 Posts
It's quite possible that one of the wheel sensors has unseated slightly and just needs to be pushed gently back. It never ceases to amaze me how many repair places want to change things rather than fix things.
FWIW, my 95' still has the original wheel sensors.
 
1 - 3 of 3 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top