Land Rover and Range Rover Forum banner
1 - 5 of 5 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
hi

my father owns an 02 d2 se7. right now we are having issues; the traction control, hill descent, and abs lights light up on the dash, they don't flash but illuminate continuously. it happened when we were replacing brake pads.the warning lights just light up, but doesn't affect driving, drives fine.

my question is, if we disconnect the battery, will that reset the system as that the errors/warning lights (tc, abs, hdc) will be fixed? will it cause other errors once battery is reconnected like not being able to shift out of park?

thanx in advance
-mal-
 

·
Premium Member
Joined
·
1,098 Posts
dude i have been driving with those light for months now. they ARE a pain to look at but they are even more of a pain to get reset (the dealor or land rover tech will have to reset them and we all know that gets expensive!!!). I say if you can deal with the lights, leave them there. You may however have a bad speed sensor or something and your traction control and hill descent may not function properly. hope tis helps and yes i wish the battery idea would work. sometimes i try it just to see if i will get lucky one time :lol:
 

·
Premium Member
Joined
·
2,367 Posts
holy crap!...this must be the season for these lights...not only have mine gone off but there has been 5 or so threads on this in the past couple weeks!!!

You cant reset them with the batt.....hehe...I tried that. It doesnt cause problems, it just doesnt work....resets your clock amoung other things. You will need to take to a dealer or an independent rover shop that has Testbook. They will either reset the codes or tell you what is wrong (and what you have to buy/fix).

The common reason is an ABS hub sensor problem; dirty, or busted. They are around $80 new.

When I just had this problem it turned out that I had somehow tripped something to make the ECU think my rover ran on air bags (air suspension), vs coil springs. It couldnt detect the coil springs so I had the lights turn on.....very stange.

for more info on this search the forum for "ABS light" and you will get plenty of stuff.
 

·
Registered
Joined
·
523 Posts
Mine went on again yesterday.I turned the truck off for a couple minutes, used the hill descent for a couple more and did a couple of harsh brakings, in case something was trapped or dirty.It solved the problem so far.

Carlos
 
1 - 5 of 5 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top