Land Rover and Range Rover Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
so about 2 months ago i pulled into my driveway and let my discovery 2 idle .as i am sitting there my water pump starts making a knocking noise.so i order a new one and figured since i am going to be already taking stuff off i should do the timing chain and gears.i had rebuilt the ever got to do the front of the motor so it probable needs it now.so now that i am already buying the water pump and timing kit i go ahead and buy new crank sensor and cam sensor with new coil packs, plugs, wires.so i do the front of the motor first and i get it back together and i am not getting oil pressure.besides that the motor for the couple seconds i had it on sounds great.so i pull the thing all the way apart again and find out i ripped a o-ring in the pick up tube.i start putting it back together and i go for a ride on my bike since i got my car apart.well 3 days later i wake up in the hospital with a broken back and shattered knee.so all i have is a broken car because my bike was a total lose.so i start putting the thing back together again and when i get to the plugs i tell myself i never want to do these plugs and wires again.now the doctor does not even want me walking and i am out trying to put my disco back together.i do the coil pack relocation but instead of buying the kit.i cut the connectors to the coil packs off and extend them myself buy soldering peaces of wire in between where i cut and to the new location about 1 and a half feet away.so now i get the whole thing back together and it is misfiring everywhere and i cannot figure it out for the life of me.i am getting codes p1300,p1884,p0300,p0301,p0304,p0306.i thought it might be the timing chain is off a tooth but i am getting 120 lbs on a compresion test in all 8 cylinders.so now i am thinking that maybe the wires that i extended need to be redone using protected wires that are screened.please someone help.i got 500 dollars to fix this and i dont no what to do next.
 

·
Expert Crate Digger
Joined
·
263 Posts
Check your engine fuse box for any blown fuses. Maybe 15A fuse F2?
 

·
Registered
Joined
·
1 Posts
so about 2 months ago i pulled into my driveway and let my discovery 2 idle .as i am sitting there my water pump starts making a knocking noise.so i order a new one and figured since i am going to be already taking stuff off i should do the timing chain and gears.i had rebuilt the ever got to do the front of the motor so it probable needs it now.so now that i am already buying the water pump and timing kit i go ahead and buy new crank sensor and cam sensor with new coil packs, plugs, wires.so i do the front of the motor first and i get it back together and i am not getting oil pressure.besides that the motor for the couple seconds i had it on sounds great.so i pull the thing all the way apart again and find out i ripped a o-ring in the pick up tube.i start putting it back together and i go for a ride on my bike since i got my car apart.well 3 days later i wake up in the hospital with a broken back and shattered knee.so all i have is a broken car because my bike was a total lose.so i start putting the thing back together again and when i get to the plugs i tell myself i never want to do these plugs and wires again.now the doctor does not even want me walking and i am out trying to put my disco back together.i do the coil pack relocation but instead of buying the kit.i cut the connectors to the coil packs off and extend them myself buy soldering peaces of wire in between where i cut and to the new location about 1 and a half feet away.so now i get the whole thing back together and it is misfiring everywhere and i cannot figure it out for the life of me.i am getting codes p1300,p1884,p0300,p0301,p0304,p0306.i thought it might be the timing chain is off a tooth but i am getting 120 lbs on a compresion test in all 8 cylinders.so now i am thinking that maybe the wires that i extended need to be redone using protected wires that are screened.please someone help.i got 500 dollars to fix this and i dont no what to do next.
Sorry about your accident You must be a good mechanic You are to be commended for your skill level I have a 92 RR just installed a fuel pump and water pump Rest for you
 
1 - 4 of 4 Posts
Top