Land Rover and Range Rover Forum banner
1 - 4 of 4 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
Help

My 96 300 TDi just stops for no reason when I am driving ( just like you had turned the key of ) It will not start again for about 5 mins or so and then will run ok for another few days sometimes even a few hundred miles and then do it again. We have had a look and dont think is dirty fuel. the Discovery is serviced evert 5000 miles and filters changed :) :shifty: :shifty:
 

·
Premium Member
Joined
·
16,594 Posts
How about the fuel pump or more so the fuel pump relay??
Mike J.
 

·
Registered
Joined
·
16 Posts
TDI has mechanical lift pump so has no fuel cut out relay!.
Look at back of injector pump if it has a single wire to the stop solenoid check the connection, if no better remove stop solenoid check for swarf (if any inj pump u/s), remove plunger and spring from stop solenoid and refit and test drive if prob has gone away either your stop solenoid is u/s or you have a wiring fault.
If you have more than one wire going to the back of the injector pump you will have the later immobiliser system which is famous for an item called the spider unit failing,the spider unit which is the immobiliser brain and is buried deep in the dash but is not to bad to change although i have never done it!
If none of the above cures it you will have to start on the fuel system.

Lynall
 
1 - 4 of 4 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top