Land Rover and Range Rover Forum banner
1 - 4 of 4 Posts

·
Registered
Joined
·
115 Posts
Discussion Starter · #1 ·
I recently came upon my Disco and it wouldnt start, the lights were off and the battery is fairly new. I was has anyone with a disco I ever find their vehicle unable to start and that the battery died? Is it just me? or is it the lucas electric system?
 

·
Forward!
Joined
·
2,324 Posts
Do you get anything electrical at all coming on ie:idiot lights on the dashboard, headlights, anything? This may sound like a stupid question but, why did you replace the battery? Did you have any previous problems to warrant a replacement? Maybe the alternator just decided to leave this world, and you were just driving off the battery. Let us know a little more info.

Good luck!
 

·
Registered
Joined
·
229 Posts
Electrical Problem

RickyRover said:
I recently came upon my Disco and it wouldnt start, the lights were off and the battery is fairly new. I was has anyone with a disco I ever find their vehicle unable to start and that the battery died? Is it just me? or is it the lucas electric system?
The first thing i would do is fully charge the battery then undo the neg cable
and put a test lamp between neg batt terminal and neg cable terminal to see
if you have a drain of some sort .If you have any kind of drain you must track
drown and isolate the circuit.You can slowly pull one fuse out at a time until the test lamp goes out and when it does that is the circuit where the drain
is you hope you then have to be like sherlock holmes and track down the drain in that circuit.

If no drain then reattach neg batt term start vehicle. Place a voltmeter across
pos and neg terminals voltage should read appr 13.2-14.5 At idle. If reading
lower than 13.2 you want to check your serpentine belt, belt tensioner,if they
check out ok then your alternator might be the culprit.

GOOD LUCK
 

·
Registered
Joined
·
115 Posts
Discussion Starter · #4 ·
sorry about the confusion guys, but what i meant about a fairly new battery was that at last check it had a good amount of juice in it, the head lights do go back on but it is relatively dimmer than before. The radio needs to get the code inputed back in. And Disco Incubus, thanks for info on dianosing the electrical problem. i guess im goin to try to find out tonight what it was that or have the disco die out again, hahaha, well what could we expect from a Land Rover, hahaha, darn lucas electrical, oh well
 
1 - 4 of 4 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top