Land Rover and Range Rover Forum banner
1 - 6 of 6 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
I recently purchased a 2001 Land Rover Discovery. It has very few miles and is in excellent condition. I have really enjoyed driving it. After having it for 2 months a warning light appeared today. The Manual Mode (M) and Sport Mode (S) lights flash together. According to the manual this indicates an electrical fault with the automatic gearbox. Does anyone have any advice or experience with this? I had it towed to the dealer, but I am concerned. Thanks.
 

·
Registered
Joined
·
121 Posts
hi, it is possible that the lights have come on due to a fault in the system,however the most common cause is that it has been put into gear too soon after starting the engine.I know this sounds daft but it uses a bus system to communicate and if it's put into gear too quickly it beats the system.When interrogated by T4 it will probably say something like "can timeout error",if this is the case 9 times out of 10 it just needs the memory cleared,job done.
Hope this helps.
 

·
Premium Member
Joined
·
16,594 Posts
So what is a few miles on your D2?
How often do you service the transmission?
What sort of driving were you doing when the light came on?
Mike J.
 

·
Registered
Joined
·
13 Posts
i'm just say this it might help ok if i'm wrong thats just life ,i've got a auto myself and sometime i get in and turn the key not noticeing i've pressed the alarm button , going down the road i noticed the same lights i stopped pressed the alarm to open the doors and the lights go off try it u never know :eek:
 
1 - 6 of 6 Posts
Top