Land Rover and Range Rover Forum banner

21 - 34 of 34 Posts

·
Registered
Joined
·
23 Posts
Update: After a few weeks of fighting with the cluster floating in the car (unbolted and dash surround apart), so when an "episode" happened i could move it around to make it normal again... i finally did some further disgnostics... ie. poking and proding... it appears the connector was very loose (probably throwing off some of the pins), so i wedged some cut off zip ties in there as shims and it appears to work fine now! 2 weeks of driving around ok. i guess that was the problem! just a loose connection! hopefully.
 

·
Registered
Joined
·
1 Posts
Update: After a few weeks of fighting with the cluster floating in the car (unbolted and dash surround apart), so when an "episode" happened i could move it around to make it normal again... i finally did some further disgnostics... ie. poking and proding... it appears the connector was very loose (probably throwing off some of the pins), so i wedged some cut off zip ties in there as shims and it appears to work fine now! 2 weeks of driving around ok. i guess that was the problem! just a loose connection! hopefully.
What about die electric grease?
 

·
Registered
Joined
·
10 Posts
OK, so I took it to the shop. Evidently is was the instrument cluster, which the medium BUS passes through. everything is fixed but they are saying they have to run some kind of reprogramming step and they have to get the codes from Land Rover. Land Rover America can't help them out so they are waiting on Land Rover UK. I assume it is associated with my VIN or something. Does this sound right?
I have the same problem with my 2007 Range rover Sport (RRS) HSE. The tire pressure lights come and go off, the parking brake light is on, and I get this message "vehicle fault, system shutting down (at times when I drive). I suspected the instrument cluster (IC) was bad (based on my reading) and a RRS dealer told me if that is the problem, a new IC needs to be made in the UK specifically for the car and the mileage. I have question, How did you get an IC and who installed it? The dealer told me that a used part will not work for a RRS. Thanks
 

·
Registered
Joined
·
10 Posts
OK, so I took it to the shop. Evidently is was the instrument cluster, which the medium BUS passes through. everything is fixed but they are saying they have to run some kind of reprogramming step and they have to get the codes from Land Rover. Land Rover America can't help them out so they are waiting on Land Rover UK. I assume it is associated with my VIN or something. Does this sound right?
I have the same problem with my 2007 Range rover Sport (RRS) HSE. The tire pressure lights come and go off, the parking brake light is on, and I get this message "vehicle fault, system shutting down (at times when I drive). I suspected the instrument cluster (IC) was bad (based on my reading) and a RRS dealer told me if that is the problem, a new IC needs to be made in the UK specifically for the car and the mileage. I have question, How did you get an IC and who installed it? The dealer told me that a used part will not work for a RRS. Thanks
 

·
Registered
Joined
·
1 Posts
OK final update. It was indeed the instrument cluster. Still not sure if it was indirectly related to the medium speed bus.

Here is what went down:
1. Auto service installed new instrument cluster and they could not reprogram it. It turns out it had been programmed, sent back to Land Rover and then sent to my mechanic and was locked down. Land Rover ackknowledged this was a problem in an email they showed me.
2. Land Rover sent a new one, they installed it, programmed it and everything has worked fine since.

I ended up spending about 1200.00 total
60.00 for a tow.
300.00 for them to pull the bus and look for bad wiring. This lead to the discovery of the instrument cluster shorting
500.00 for a new instrument cluster.
250 to install the cluster.

Hope this thread helps someone in the future!
Did the problem ever come back? Thanks!!
 

·
very disco
Joined
·
1,951 Posts
For what it’s worth, I read many tales of folks smacking the dash, using zip ties on the harness, etc... none of those worked for me. My RRS had panic attacks regularly, and what solved it was a used IPC from eBay (around $90 shipped) and a quick reflash with my nanocom
 

·
Registered
Joined
·
2 Posts
I am having some problems with my 2006 LR3. It started with the Tire Pressure warning light turning on. Then the truck wouldn't turn over. It wouldn't even try to start. Then I would see a Tire Pressure Monitoring Fault. I could get in and the car would start randomly. So It started and began to drive down the road and on the stereo I see something like Vehicle Fault: System is shutting down. Then the stereo and A/C and Dashboard shut down. Then when I got back home and put the car in park, I got a Parking Break Fault message and the parking break light started blinking.

Any ides as to how to troubleshoot this issue? Thanks for any help.
having same problem if islap the dash all comes on again for a bit then off. if it wont start i slap the dash and it starts. any ideas
 

·
very disco
Joined
·
1,951 Posts
You need a new IPC
 

·
Registered
Joined
·
2 Posts
You need a new IPC
would this be the whole instrument panel control or is there any way to isolate the fault from what i have seen the there is a "sj117" in there somewhere, that is part of the radio/nav/console however at this "sj117" there are also connections for the windows, cigar lighter, and other stuff. the windows work everything else works just the radio and nav


thanks for the reply
You need a new IPC
 

·
very disco
Joined
·
1,951 Posts
There are places which offer IPC repair. It’s a common issue, though I don’t know the specifics. I replaced my IPC it was easy, but you’ll need a means of flashing your CCF to the replacement
 

·
Registered
Joined
·
2 Posts
I am having some problems with my 2006 LR3. It started with the Tire Pressure warning light turning on. Then the truck wouldn't turn over. It wouldn't even try to start. Then I would see a Tire Pressure Monitoring Fault. I could get in and the car would start randomly. So It started and began to drive down the road and on the stereo I see something like Vehicle Fault: System is shutting down. Then the stereo and A/C and Dashboard shut down. Then when I got back home and put the car in park, I got a Parking Break Fault message and the parking break light started blinking.

Any ides as to how to troubleshoot this issue? Thanks for any help.
 

·
Registered
Joined
·
2 Posts
I am having some problems with my 2006 LR3. It started with the Tire Pressure warning light turning on. Then the truck wouldn't turn over. It wouldn't even try to start. Then I would see a Tire Pressure Monitoring Fault. I could get in and the car would start randomly. So It started and began to drive down the road and on the stereo I see something like Vehicle Fault: System is shutting down. Then the stereo and A/C and Dashboard shut down. Then when I got back home and put the car in park, I got a Parking Break Fault message and the parking break light started blinking.

Any ides as to how to troubleshoot this issue? Thanks for any help.
In my 2016 LR4 this happened and then my car started smoking and then went up in flames after I pulled off of the interstate or scooted after the wheels locked and engine smoking . Apparently that isn’t uncommon in the missed boxy model of Land Rover.
In my current new 2020 landmark edition LR discovery, I had this happen and had PTSD from my three month prior car fire. The first time this happened in the Disco was one month into its life with me and dealership said because I had auto suspension turned on and I put my car in park and undid my seatbelt (suspension lowered ) then seconds later before opening the door put it back in Drive as I no longer needed to exit the car, the car was as they put it “ catching up to me “ electronically speaking - I guess it is one big computer anyways but it freaked me out because the gear knob was blinking, screen going black then going blinding white ( it was around 11pm in BFE Alabama Smith Lake without service ) and then it just turned off, and after I turned back on had blinking messages then was almost like I confused the heck out of the system... I’m sorry I realized I did have my wallet... go figure . Turned that option off due to my fire trauma being reinitiated ...

Second time it happened in my Disco was about two weeks before Christmas ( 2020) and I was with a friend heading back from the same mall o was coming back from when LR4 exploded ( crazy right?). It was 20 something out and all of a sudden the heat shut offf and was only blowing bone chilling freezing AC. Then the gear knob started blinking... I went into my state of trauma and was like I need to get out of this thing before it explooooddddeees.... well the monitor where the gas gauge is started blinking furiously with messages about each different option/ car part ( breaking, airbags, ect... literslly couldn’t even read it all it was warning a new message so fast..both screens went from blacked out then went to that bright white then did a dance between the two backgrounds ( yes BOTH the media one and the gas one) . at this point I’m at a red light and it just shut off completely. I panicked ... of course... and pulled over turned the car off and called my new buddy head of sales on his cell and asked WTF ... I let it sit for about 10 then turned back on and it was as if I was a crazy person asking my friend if she was also witness to what happened or if I am going mad... Turns out it it was a combination of both a newly announced recall for a piece that can cause auto shutoff ... Whattt? And also an issue with the system updates I apparently were supposed to be manually doing correctly but wasn’t. I had been selected “yes update now” when a system update notice would appear a few weeks prior to this - only happened two or three times when I would park my car but I always said yes... well didn’t know but you have to lock the car, connect to your home wifi and then it will update your car.... cool would have been nice to know that ... because if you don’t the above can happen just like when you don’t update your windows system on your computer... it’s starts to freeze and shut off and become an utterly useless disaster... well cars are now the new computer and I don’t like it because it Is scary as F... especially when prior fire and totally burn down of my LR4 and when you have three kids ( 8,6,1 months ) you tote around all day every day in that same car that can randomly shut off if you don’t correctly update your system. Praise the Lord I was at a red light, right ? And not on the freaking interstate . Anyways I’m ranting and moaning but I still have my Disco and still a loyal LR customer because you Can’t beat that smooth ride from the air suspension... but I am starting to question why I’m trying to torture myself for a $80k car.... hmmmm... anyhoo the issues could be either :
1. Electrical issues - car might explode in 3...2...1
2. You’re performing system based actions that are moving too fast for the vehicles mind to work and throwing it off
3. You have a system update that hasn’t been 100% finished ( there are two kind to do each time there is an update needed 3-5 times a year)
4. You have a recall in some tiny part that can possibly cause car shut off at worst but random electrical issues like screen display.
Good luck! Best advise is get to know your dealership upper management and service department leaders if you love you LR and the LR / RR experience because that is the only reason I’m probably still with them... at least the one in Canonsburg, PA is wonderful/ I have their cell numbers and they will answer me, text me for however long day, night, weekend, 6 am, whatever and get me through the moment and get me in and take care of whatever is going on & if it’s purchased new of CPO no need to fret the crazy costs associated with these vehicles.
Good luck! Hope that provides someone with come insight!
 
21 - 34 of 34 Posts
Top