Land Rover and Range Rover Forum banner
1 - 5 of 5 Posts

· Registered
Joined
·
22 Posts
Discussion Starter · #1 ·
While I was standing still doing nothing in a car park tonight, my one year old LR3 went into extended mode again. It does this with increasing frequency - at least once a week.

Another suspension error. The dealer says LR Canada has never heard of this problem and has no idea what it might be. Is that so? No-one else with the same issue?
 

· Former LR tech, Albany NY
Joined
·
2,437 Posts
sounds like either a short in the switch pack or the module itself.

Could be the result of water intrusion or some wires that short out every now and then.

it wont be easy to track thats for sure.

I'd leave the vehicle with them for a while to make sure they can duplicate the problem. and then take the time to properly diagnose it.

Some of these new ones we have had computer problems with that arent easy to fix. Its pretty much looking at all the data coming in and finding out where the program is bad.
 

· Registered
Joined
·
22 Posts
Discussion Starter · #3 ·
It was in the shop quite a bit when it was new - wiring loom changed out, then heigh sensors changed - now it loosk like yet another wiring/sensor problem. And intermittent, so it may be impossible to fix. My worry is that it becomes a REAL error two years from now when the warranty is out.. grr!
 

· Former LR tech, Albany NY
Joined
·
2,437 Posts
I apologize vehicles like that sometimes have problems installed in them and it drives the shops crazy cause its impossible to fix. It can happen in any and all lines of cars. Its really frustrating. More then likely its something small that can be overlooked. Its time like that field engineers get involved to see what the heck is going on. I have seen it in all the manufacturers I have worked for. The shops really try to fix the problem. Its just the answer doesnt pop out in front of them and when its intermitten its just that hard to diagnose.
 

· Registered
Joined
·
22 Posts
Discussion Starter · #5 ·
Oh, don't get me wrong: I am not assigning any blame at all. I work in technology meself and know all about intermittent problems. And the shop as well as LR Canada have been very good about it - I just hope they continue until they fix all the issues!
 
1 - 5 of 5 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top