Land Rover and Range Rover Forum banner
1 - 7 of 7 Posts

· Registered
Joined
·
19 Posts
Discussion Starter · #1 ·
2004 Land Rover Discovery (well maintained) 80k miles.


Ok here are the symptoms,

Down Shifting from 2nd to 1st, there is an audible clunk.
If I shift to neutral from Drive and coast before I stop then it does not happen.
All other shifting and RPMs are normal.
No dash lights on.
All u-joints seem to be OK.

Any help would be great. Thanks guys.
 

· Premium Member
Joined
·
16,548 Posts
U-Joints never seem right if you don't know what you for.
Have you ever had the front shaft rebuilt, how often do you grease the u-joint?If it goes not have 1 grease fitting on each of the u-joints you better stop driving it before it fails and takes the tranny out also. Also inspect the rear roto-flex for bad cracks and replace if needed. If the shaft has not been checked/greased I would suggest you remove it and drive in Hi Lock until you fix it.
How mechanical are you and when was the last time you did a major service on your Disco like the one posted at the top of this section?
 

· Registered
Joined
·
19 Posts
Discussion Starter · #3 ·
Thanks Mike,

I have done just about all of those on the list except

PS flush (happening Friday)
Induction cleaning
T-stat change
Tranny fluid/filter service.



The front shaft has been rebuilt, and to be honest it's not greased at every 3k. More like every 5k or 6k.

The rotoflex was good 2k ago when I had the drive shaft out.

This noise only happens when coming to a stop, when the tranny shifts down into 1st gear. And it does not happen every time.


From what I can tell, it seems to be a trans shift issue. Like an electronic shift solenoid maybe (just speculation)......

Oh, and I am a fairly mechanical.
 

· Premium Member
Joined
·
16,548 Posts
Do you grease the slip shafts on each shaft, was the centering ball replaced when you rebuilt? Any fault codes?
 

· Premium Member
Joined
·
16,548 Posts
Mike,

I grease everything on the shafts.

No codes.

And as far as the ball, I do not know, the shaft was rebuilt before I purchased it.
If you want some more help, PM me your number and I'll call you today.
 

· Premium Member
Joined
·
16,548 Posts
Mike,

I grease everything on the shafts.

No codes.

And as far as the ball, I do not know, the shaft was rebuilt before I purchased it.
If you want some more help, PM me your number and I'll call you today.
 
1 - 7 of 7 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top