Land Rover and Range Rover Forum banner
1 - 5 of 5 Posts

·
Registered
93 LWB KITTED 95 LWB Chop Top 03 D2
Joined
·
213 Posts
Discussion Starter · #1 ·
I was dealing pretty well with the lack of interior lights, but now since i was working on my radio the dash lights have gone completely. I wasn't messing with anything really. I hard wired the radio right to the battery ( yes i put a fuse ).. anyway my fuse cover has no sticker ( should be in the mail box this afternoon..) but last time there were no fuses that were bad. Is there a relay that i need to check??

TIA

93 Dub !
 

·
Registered
Joined
·
95 Posts
The interior light stays on after exiting the vehicle so some circuit must control this, could be bad if not fuse.

Radio has light (or brightness control) which is usually connected to dash lights. If you connected this improperly could be casue of problem.
 

·
Registered
Joined
·
674 Posts
I have the interior light problem on and off - I traced it back to my back hatch issue....you can tell when using the remote to the alarm. If the indicators blink 3 times when arming all is OK....if they blink hard once something is not closing all the way correctly. So I traced it to the back hatches, because they flex somtimes one side will not click and latch correctly - thus telling the "brain" that the hatch is still open - therefore for some reason the front dome light will not work! Dang Lucas folks..........I used your fix for the back hatch...using tape! Great idea and this helped fooling it!!!!

Dunno about the dash lights - sorry
 

·
Registered
93 LWB KITTED 95 LWB Chop Top 03 D2
Joined
·
213 Posts
Discussion Starter · #4 ·
I tossed the stock radio for a Blaupunkt and Earthquakes

put in a 220w Blaupunkt, so I don't think its anything to do with that, unless some of the wiring back there got pinched, or cut or shorted when i put the aftermarket radio in there. Hmmmm.. I bet its just a fuse.. As Far as the alarm.. I didn't even know my car had one... i guess they are standard, but mine has never gone off.. I was planning on putting an aftermarket unit with remote unlock and pager as soon as i had some extra cash.

Regarding the tape on the rear hatch.. glad it works for you.. I have used duct tape and electrical tape before, and i think the electrical tape works best.

D..
 

·
Registered
93 LWB KITTED 95 LWB Chop Top 03 D2
Joined
·
213 Posts
Discussion Starter · #5 ·
Still no lights .. Got the Sticker to check the fuses

The fuses are not the problem. Wierd thing happened when i put it in park with the headlights on, the lights on the shift guage went on. I put it back in Drive and the lights went off again.. wierd. Ohh well the truck is running great otherwise.. I put some of that leak seal in the expansion tank, and I think its finally making its way though the radiator.. I no longer smell coolant..

D
 
1 - 5 of 5 Posts
Top