Land Rover and Range Rover Forum banner
1 - 14 of 14 Posts

·
2001 DiscoII SE7
Joined
·
16 Posts
Discussion Starter · #1 ·
Wipers and Turn Signals don't work until car is up to temperature, more or less. I don't know what the two have to do with each other if anything, temp. of the engine and the electrical, but this is what is happening.

What causes a long, several minute delay of getting the wipers and signals to work when starting the truck cold?? Didn't have a problem with the blinkers initially but now there is one.
Thanks in advance.
 

·
2001 DiscoII SE7
Joined
·
16 Posts
Discussion Starter · #7 ·
Glad I'm not the only one with weird electrical gremlins. I've never had this type of issue in any of my other cars (Toyota, Jeep, Chevy, Pontiac).

Guess I'll check out the alternator and battery (both are new within last couple/few years) but any other ideas would be appreciated.
 

·
And I didn't even submit a proposal...
Joined
·
202 Posts
About the wipers, it could be the contacts in the stalk that are dirty. That problem is well documented on this site, if that's the case. The easy solution is to replace the entire stalk assembly and I'd say it's a 30 minute job, and pretty easy. I did it two years ago and it got rid of the problem. The turn signal I think is less frequent. But since it's turned on with a stalk too, maybe they share the same design? I'd certainly look that way first.
 

·
Registered
Joined
·
380 Posts
Its the switches. My blinkers have a delay in cold, as does my wiper blades, but I honestly could care less... as long as they work, I replace them when it gets too bad. Its also around 350$ in parts for both wiper switch and the turn signal switch. It may be a weird problem but I've learned to just tell myself when replacing anything on my truck that, hey, it lasted 13 years, not to bad, nothings perfect. Keep that attitude and you'll love your rover as much as I do and wont sweat most repairs.
 

·
2001 DiscoII SE7
Joined
·
16 Posts
Discussion Starter · #11 ·
About the wipers, it could be the contacts in the stalk that are dirty. That problem is well documented on this site, if that's the case. The easy solution is to replace the entire stalk assembly and I'd say it's a 30 minute job, and pretty easy. I did it two years ago and it got rid of the problem. The turn signal I think is less frequent. But since it's turned on with a stalk too, maybe they share the same design? I'd certainly look that way first.
Thanks, I'll give this a shot!
 

·
Registered
Joined
·
122 Posts
About the wipers, it could be the contacts in the stalk that are dirty. That problem is well documented on this site, if that's the case. The easy solution is to replace the entire stalk assembly and I'd say it's a 30 minute job, and pretty easy. I did it two years ago and it got rid of the problem. The turn signal I think is less frequent. But since it's turned on with a stalk too, maybe they share the same design? I'd certainly look that way first.

This. i am going to do my headlight stem tomorrow.
 

·
Registered
Joined
·
87 Posts
When it gets very cold (teens or single digits) my turn signals have a delayed "hiccup" starting. I hit the turn signal and there is a few second delay before they start. Once the vehicle is warmed up, it's fine. I was guessing it was the mechanical portion of the relay switch being very cold, but that's just a guess??
 

·
Registered
Joined
·
122 Posts
Got my light switch out and cleaned with degreaser(Mean Green) and rubbing alcohol. Then re-lubricated with vaseline, which is working great with my wipers switch. The light switch is easier to do than I remember the wiper switch being. Just make sure to test it before you put it back in, but it is straightforward.

The grease appeared to have broken down into a lighter grease that bled out to underneath the switch, and into a dark blue gummier substance that had to be picked off the switches with a toothpick.

The only other experience I have had with this type of issue is with some Shimano 9 speed shifters. Those were unsalvageable.
 
1 - 14 of 14 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top