Land Rover and Range Rover Forum banner
1 - 6 of 6 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter · #1 ·
:eek:
HERES ONE FOR YOU GUYS THEN.
WHEN I INDICATE TO TURN RIGHT A GREEN TRAILER FLASHES ONCE THIS IS NORMAL BUT WHEN I INDICATE LEFT IT KEEPS FLASHING IN CONJUCTION WITH THE INDICATOR,
I HAVE CHECK THE INDICATORS AND THEY SEEM TO BE WORKING FINE,
COULD ANYONE GIVE ME THERE THOUGHTS ON THIS.
MANY THANKS FOR ANY REPLYS
 

·
Premium Member
Joined
·
10,236 Posts
do you have trailer wireing on your rover?
 

·
Registered
Joined
·
150 Posts
I guess that's 'MOGWAI' off 'Mud-Club'.

See the replies there
 

·
Registered
Joined
·
1 Posts
zerocool said:
:eek:
HERES ONE FOR YOU GUYS THEN.
WHEN I INDICATE TO TURN RIGHT A GREEN TRAILER FLASHES ONCE THIS IS NORMAL BUT WHEN I INDICATE LEFT IT KEEPS FLASHING IN CONJUCTION WITH THE INDICATOR,
I HAVE CHECK THE INDICATORS AND THEY SEEM TO BE WORKING FINE,
COULD ANYONE GIVE ME THERE THOUGHTS ON THIS.
MANY THANKS FOR ANY REPLYS
Check the trailer socket itself - most likely it's full of damp mud or something and is causing just enough current to pass to make it think there's a trailer attached. Had the same on mine :mad:

A good squirt of WD40 or some other protective stuff is normally enough to restore things back to normal :drive:

The trailer light is SUPPOSED to flash when there's a trailer attached to let you know the bulbs are working :wave:
 
1 - 6 of 6 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top