Land Rover and Range Rover Forum banner
1 - 8 of 8 Posts

·
Registered
Joined
·
27 Posts
Discussion Starter · #1 ·
My 90 range when cold is very hard starting after about 5 minutes of cranking it will start. when warm it will start fine though i but has a bad hesitation when running, the idle is a little erratic too. i replaced the fuel filter and tried to replace the pump with a borg warner p39 pump but that didnt work! i put a "standard" brand coil in it could this be the problem? iam banging my head against the wall on this now i does smell like it is running very rich maybe fuel pressure regulator? it has to be a fuel issue what do you think? :dunno:
 

·
Registered
Joined
·
1,818 Posts
The symptoms you describe sound like the Idle control valve (Stepper motor)has got gummed up a little. You can clean this with carb cleaner or similar solvent.
 

·
Registered
Joined
·
27 Posts
Discussion Starter · #6 ·
Ok i checked the idle air control valve by swapping them with the one from my 1990 gmc truck both worked fine in either truck. so i have narrowed it down to the fuel temp sender. can i take it out and swap it with the manifold temp sender? they do look identicle just for test sake?
 

·
Registered
Joined
·
79 Posts
Lucasfree said:
Ok i checked the idle air control valve by swapping them with the one from my 1990 gmc truck both worked fine in either truck. so i have narrowed it down to the fuel temp sender. can i take it out and swap it with the manifold temp sender? they do look identicle just for test sake?
Just out of curiosity, what exact model/year/engine is your GMC truck? I have been looking for a cheap replacement IAC valve that someone has actually cross-tested.

Thanks!

-Coach
 
1 - 8 of 8 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top