Land Rover and Range Rover Forum banner
1 - 9 of 9 Posts

· Registered
Joined
·
9 Posts
Discussion Starter · #1 ·
I just got a 03 disco II and it is perfect but when I started it the other day it started making a slight tapping noise and then it went away. but today I started it and the same thing happened but when I pushed the gas pedal the noise got louder and sounded like a tapping noise almost as if the timing chain is loose but if I let off the gas it gets a little more quite could someone please help me with this cause I would really like to fix this problem?
 

· Registered
Joined
·
172 Posts
I myself am right in the middle of the same thing. Thought it was lifters ticking but the video of the sound of loose cylinder liners. I would stop driving it. When I did t know what it was, I drove mine and it go worse. Had misfires and had no power. Water was probably getting into the cylinders. When I took the heads off, the valves looked wet. Different from the others. Right now, I'm seeing about sending my block to Great Plains rover to have top hat sleeves put in. With them, you also get a new cam that adds 3-5 mpg


Mike Russell
Age 18
2003 discovery se
Lover of Rovers
 

· Registered
Joined
·
9 Posts
Discussion Starter · #6 ·
I just got it a little while ago for a real good price because it was tapping and the body and interior are in great shape. has 103,000 miles on it. is there a way to be sure it is the sleeves or do I have to tear it down to find out?
 

· Registered
Joined
·
172 Posts
That I wouldn't know. I took mine apart to to head gaskets, but now in going to do sleeves too. My guess would be that you have to take it down to the block and and have it checked


Mike Russell
Age 18
2003 discovery se
Lover of Rovers
 
1 - 9 of 9 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top