Land Rover and Range Rover Forum banner
1 - 9 of 9 Posts

· Registered
Joined
·
13 Posts
Discussion Starter · #1 ·
The 4-way hazard flashers on my '97 Disco are not working. Fuse number 4 in the Engine Compartment fuse box is okay. Tried replacing the flasher unit and that did not fix the problem. The light on the dashboard push button glows. Who has had this problem and knows the remedy?
Bill Mac
 

· Registered
Joined
·
229 Posts
just throwing it out there but it could be a problem in the alarm unit. whenever i hit a big bump or something my alarm triggers the 4 ways...and i also think this is the problem with why my window keeps going down when i turn on/off the truck...i think i need to buy a new alarm unit to solve it...but i do know that the hazards run through the alarm... :complain:


:rellye
 

· Registered
Joined
·
1,506 Posts
Today I had a problem with the hazard lights turning on by themselves.

Here's the story:

My Disco wouldn't start so I decided to check the fuel pump relay. I removed the PS kick panel and checked the relays. I put back the kick panel and hit some relay/box that caused the hazards to turn on and disable the alarm. I was a few blocks away from Atlantic British so I decided to call Eric R. He told me to turn the ignition key on and off several times to stop the hazards from turning on and to enable the alarm again. It worked.

I'm guessing you have a problem with that relay/box.

Give Eric a call at 800-533-2210 ext 231. He's always available and more than happy to help us LR owners.

Good luck.
 

· Registered
Joined
·
229 Posts
John C said:
Today I had a problem with the hazard lights turning on by themselves.

Here's the story:

My Disco wouldn't start so I decided to check the fuel pump relay. I removed the PS kick panel and checked the relays. I put back the kick panel and hit some relay/box that caused the hazards to turn on and disable the alarm. I was a few blocks away from Atlantic British so I decided to call Eric R. He told me to turn the ignition key on and off several times to stop the hazards from turning on and to enable the alarm again. It worked.

I'm guessing you have a problem with that relay/box.

Give Eric a call at 800-533-2210 ext 231. He's always available and more than happy to help us LR owners.

Good luck.

yeh i had the problem too, just have to cycle the key, i think my alarm is fubar tho because i believe its why my window is rolling up and down on start and when i turn the rover off... :complain:


:rellye
 
1 - 9 of 9 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top