Land Rover and Range Rover Forum banner
1 - 3 of 3 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter · #1 ·
We noticed today that when we used the heated seats the passenger was working fine but the drivers side switch didn't light up & the seat didn't warm up either.

I checked fuses under seat & all are fine.

I searched the forums for answers to a switch light not turning on, but only found threads with seat not heating even though the light on switch is on.

Has anyone had this happen that can give me an idea of how to diagnose & repair.

I plan on trying to switch the driver & passenger sides to check the switch. I have also searched the Rave for answers.


Thanks in advance.
 

·
Registered
Joined
·
1 Posts
We noticed today that when we used the heated seats the passenger was working fine but the drivers side switch didn't light up & the seat didn't warm up either.

I checked fuses under seat & all are fine.

I searched the forums for answers to a switch light not turning on, but only found threads with seat not heating even though the light on switch is on.

Has anyone had this happen that can give me an idea of how to diagnose & repair.

I plan on trying to switch the driver & passenger sides to check the switch. I have also searched the Rave for answers.


Thanks in advance.
hi! I am having the same issue. Did you ever figure it out?
 

·
Administrator
Joined
·
2,423 Posts
Sounds like the bulb in the switch.
Swap switches for an easy diagnostic
 
1 - 3 of 3 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top