Land Rover and Range Rover Forum banner
1 - 2 of 2 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
So, I have what may or may not be the classic blower problem. Over a period of a week or two, my blower would stop, and start again all on its own. So here is everything I've done. First of all, I took out the controller, removed the fan speed switch, cleaned and inspected it. I put it back in, and nothing. While it was out, I inspected all wiring and harness connectors and they look great. So, I scratched my head a bit, came on the forum, and learned how the fuse box can get a bit shady around the blower fuse. I checked for power and it was all good. 12.4VDC solid. Pulled the relay, took the cover off, and that looked good too. So I wondered if the blower was bad, hooked it up to a 12 volt power supply, and it purred like a kitten. So I started combing my rover over with a fine tooth comb. Engine fuse block looks great, all wiring, harnesses and connectors look good, and I looked at the resistor, (with doubt because if it was that- at least I would have high speed). I started to pull the fuse block, as I got about two thirds done, I was afraid I was going to break it, so I reassembeled it, and put it all back. I don't get it. I have power everywhere, I've replaced the relay, blower is good, relay is good, switch is good, and both fuse boxes appear good. Then I got the genious idea of looking at the relay. I remembered having power at the relay, so I rechecked and sure enough, plenty of voltage. So, I then jumpered the connector that the relay goes into, and boom, it worked! So I popped the cover off the relay, and manualy closed the relay, and again I have a working blower, and all 4 speeds of the blower work! Let go of the relay, and it stops working! I tried the same on the old relay, and again, only works when manually closing it. I'm lost! Any input would be great! I thought I went over all this pretty good, but obviously, I'm missing something! Please help! I've also scrutinized every manual and trouble shooting book I can find!
 

·
Registered
Joined
·
65 Posts
The number one suspect will be the control panel, I have seen dozens of them fail at the LR dealer I'm at. next time it fails tap on the switch a bit and see it starts up again. Also, make sure you are using a test light with an old fashioned bulb, if you have an LED test light(or a DVOM) that could lead you astray, it does not take nearly as much power to light an LED as it does an bulb. You may have voltage, (pressure)but no amps(flow)
PM me if you need help
 
1 - 2 of 2 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top