Land Rover and Range Rover Forum banner

1 - 10 of 10 Posts

·
Registered
Joined
·
13 Posts
Discussion Starter #1
My lr3 hasn’t run for a while, theses are the codes that are coming up
P0102, U0102, U0121, P0504, U2023, U0122,U0146, B1A00, B1A87, U0300, U0402, U0403, U0421, C1A02, C1A00, U0155, U0100, U0101, P0562, P1811, P1806, P173E, U0126, U0401, C1A96, B1B02, B1C57, B1B12
B1B14

Does anyone have any ideas. It starts the shuts right off, eventually I can get it to stay running.
 

·
Super Moderator
Joined
·
2,152 Posts
I would start by clearing codes in all modules and recheck what resets
You say “a while “ How long ?
Maybe fully charge the battery
 

·
Registered
Joined
·
13 Posts
Discussion Starter #3
It hasn’t run for about 8 months. This issue started then I just haven’t been able to get it to a Land Rover mechanic, the closet one is 3 hours away and I have to tow it. The suspension won’t stay aired up.
 

·
Super Moderator
Joined
·
2,152 Posts
You have codes in multiple modules.
Try clearing with key on engine not running.
 

·
Registered
Joined
·
13 Posts
Discussion Starter #7
Ok cleared the codes with ignition on, there was no change. Once I cleared them they all came right back on.
 

·
Super Moderator
Joined
·
2,152 Posts
What are you using for a diagnostic tool?
When it is running can you view live data?
 

·
Registered
Joined
·
13 Posts
Discussion Starter #9
I am using a iCarsoft Multi-system Scanner i908 programmed for a Land rover, and I do believe it can view live data.
 

·
Registered
Joined
·
13 Posts
Check the main ground cable from battery. It may be loose or corroded. Some codes are loss of communication codes and this is most probably intermittent loss of power related. May be reason for engine shutting down right away because engine vibration causes power to lose ground.
 
1 - 10 of 10 Posts
Top