Land Rover and Range Rover Forum banner
1 - 4 of 4 Posts

·
Registered
Joined
·
37 Posts
Discussion Starter · #1 ·
Changing plugs on my 06 LR3 HSE @120k. 7 of 8 no issues. The problem child is the driver side plug closest to the fire wall. The end cap on the ignition coil did not come with the body as I removed the coil assembly. So, i cannot get a socket on the plug as it blocks it.

I was thinking about putting some glue on the coil shaft, reassemble, then trying remove after it dries. Any other ideas how to get it off or access it?
 

Attachments

·
Registered
Joined
·
63 Posts
Boy, talk about weird timing. I just had this happen to me yesterday and posted about it on another board. What worked for me was purchasing a set of long "picks" from Harbor Freight and sticking the pick into the boot as hard as I could, then pulling up. After a couple of attempts, I managed to get it out.
My ordeal...
 

·
Registered
Joined
·
63 Posts
By the way, I ordered a new coil pack from BPUtah to replace the one that lost it's boot. I ordered an aftermarket coil pack, so I'm not sure this applies to the LR ones, but my new coil pack is designed differently. Looks like perhaps they realized the weak spot in their design and the new packs have a much longer, more integrated boot that I doubt will fail.

Piece of advice that may help if you haven't fixed this already... I would put the "broken" pack back in if it fits and run the car until the engine warms up. At that point, I would remove the pack and try to fish the rubber boot out. It will be much softer/more pliable and more receptive to being stuck with a pick. :)
 
1 - 4 of 4 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top