Land Rover and Range Rover Forum banner

1 - 13 of 13 Posts

·
James Hewitt
Joined
·
78 Posts
Discussion Starter #1
Need a little help. I am in Greenville Nc and had to do a lot of driving yesterday in the storm. Rover handeled it all including the water around town. However, I am not getting a rough idle and a P0505 code. It says Idle control malfuntion. Rave says blocked valve. Where should I start? And where is the Valve located? I have another MAF If needed. Is there a chance I got water into the engine that would cause this? Any help would be much appreciated.
 

·
Administrator
Joined
·
16,594 Posts
Clean your t/body and idle control valve, if you don't know how send me your number and I'll call you.
Check your air filter, see if it got wet, if it did you may have a MAF failure in the near future.
 

·
James Hewitt
Joined
·
78 Posts
Discussion Starter #3
Where I am at now

Mike,

I have cleaned the T/Body, the air filter is dry and water free, MAF looks good. I have pulled the ICV off to clean it but I am not sure what to clean it with. Also I am new to this part. When I hold it up to the light I can see through it. I am not sure exactly what it is supposed to look like so I am wondering if I have a good part or not.
 

Attachments

·
James Hewitt
Joined
·
78 Posts
Discussion Starter #4
I cleaned it with t/body cleaner and put it back on the rover. Still a rough idle but no codes so far. Right after I fired it up I got a p0131 and a p0135. I cleard all codes and nothing has returned so far but she is till running rough
 

·
Administrator
Joined
·
16,594 Posts
If it keeps up, lets talk.
 

·
James Hewitt
Joined
·
78 Posts
Discussion Starter #6
It has gotten worse. I am back with the p0505 and it is a horrible idle and cuts off when I am stopped.
 

·
Registered
Joined
·
6 Posts
Meu nome é Carlos, estou com mesmo problema em uma ranger rover evoque 2.0 gasolina motor ecobost! Conseguiram descobrir a falha ?
 

·
Super Moderator
Joined
·
2,118 Posts
Hola Senior’
Sorry that’s all I’ve got for Spanish? (and not too sure about it)
This is a VERY old discovery 2 thread.

Are you asking about a Evoque?
 

·
very disco
Joined
·
1,181 Posts
I don’t think that’s Spanish lol. Maybe Portuguese or Brazilian.

no puedo jugar este juego
 

·
Registered
Joined
·
6 Posts
[QUOTE = "redtruck12, postagem: 845797, membro: 46602"]
Hola Senior '
Desculpe, isso é tudo que tenho pelo espanhol? (e não tenho muita certeza disso)
Esta é uma thread MUITO antiga de descoberta 2.

Você está perguntando sobre um Evoque?
[/CITAR]
desculpe pela minha humilde ignorância, mas não sei falar inglês, por isso estou usando o tradutor.
Eu tenho um motor evoque 2.0 ecobost a gasolina que acusa o dtc p0505-27, como o amigo relatou.
e queria saber se ele solucionou a falha, porque estou lutando para resolver essa situação há alguns meses e nada, já substituindo as seguintes peças: sonda lambda, turbina, admissão completa pelo corpo de aceleração, kit de temporização (polias , tensores, corrente), injetores, sensor maf, intercooler, todas as mangueiras do sistema de pressurização da turbina, módulo do motor e o motor ainda está oscilando em marcha lenta
 

·
Registered
Joined
·
6 Posts
[QUOTE = "reverendALC, postagem: 845800, membro: 12704"]
Eu não acho que isso seja espanhol, lol. Talvez português ou brasileiro.

no puedo jugar este juego
[/CITAR]
desculpe pela minha humilde ignorância, mas não sei falar inglês, por isso estou usando o tradutor.
Eu tenho um motor evoque 2.0 ecobost a gasolina que acusa o dtc p0505-27, como o amigo relatou.
e queria saber se ele solucionou a falha, porque estou lutando para resolver essa situação há alguns meses e nada, já substituindo as seguintes peças: sonda lambda, turbina, admissão completa pelo corpo de aceleração, kit de temporização (polias , tensores, corrente), injetores, sensor maf, intercooler, todas as mangueiras do sistema de pressurização da turbina, módulo do motor e o motor ainda está oscilando em marcha lenta
 

·
very disco
Joined
·
1,181 Posts
o post tem quase 10 anos. talvez use o google translate para converter seu idioma para inglês e postar um novo tópico.

alguns o ajudarão, mas poucos levarão tempo para traduzir
 

·
Registered
Joined
·
6 Posts
[QUOTE = "reverendALC, postagem: 845800, membro: 12704"]
Eu não acho que isso seja espanhol, lol. Talvez português ou brasileiro.

no puedo jugar este juego
[/CITAR]
[QUOTE = "jhewitt1111, publicação: 400652, membro: 32795"]
Ficou pior. Estou de volta com o p0505 e ele fica horrível ocioso e corta quando estou parado.
  1. [/CITAR]
  2. o post tem quase 10 anos. talvez use o google translate para converter seu idioma para inglês e postar um novo tópico.

    alguns o ajudarão, mas poucos levarão tempo para traduzir
    Muito obrigado
 
1 - 13 of 13 Posts
Top