Land Rover and Range Rover Forum banner

1 - 2 of 2 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter #1
Hi All,
I've had a problem for quite some time that I'm at a loss at. My basic problem is that once my motor has warmed up (90 classic swb with a 4.2 bottom end, 3.9 top end) it will sometimes start "missing" when stopped at a stop light. The tach will drop to about 500rpm it seems. If I try to pull away normally, it will have very little power- but will move. Sometimes it will correct itself and lurch forward under power. Sometimes it does not. If I floor the gas pedal- it will clear up 100% of the time. If I release the gas and repress, it will fix the problem about 1/3 times.
If I sit at a light long enough while it is doing this, and it doesn't happen at every light, sometimes the ecu seems to adjust to give it more fuel and it runs perfect.
-If I unplug my MAF, the truck runs perfect 100% of the time, just really rich.
I've had it hooked up to rovergauge and found that at idle, my iacv reads 0-3% generally. I get up to 40% on that when running the truck hard. One other curious note about rover gauge is that I get no reading for target idle.

Here's what I have done.
-replaced IACV
-replaced all temp sensors
-tried out multiple maf's that are known working.
-changed out t valve
-changed out multiple vaccuum lines
-installed genuine 02 sensors
-new battery
-new coil
-cleaned and checked grounds on engine
-adjusted base idle per rave
-checked for tps function, and checked with known unit
-cleaned IACV seat and lubricated.
-cleaned butterfly
-replaced Ignition amplifier
-replaced plugs and installed 8mm wires
-tried to test a new junkyard ecu, same problems but unknown quality of unit. I've opened mine up and it looks fine, but looks can be deceiving.
I think that's about it, I've done pretty much everything I can think of. Any help would be greatly appreciated.
 

·
Registered
Joined
·
598 Posts
ill take a stab at it... have you replaced the fuel filter?
and maybe try adding some seafoam to the gas .. then let it go a bit... then some injector cleaner....may be a fuel problem...
 
1 - 2 of 2 Posts
Top