Land Rover and Range Rover Forum banner

1 - 7 of 7 Posts

·
Prepping for the Ebola Zombie Apocalypse
Joined
·
62 Posts
Discussion Starter #1
Okay, she's only got 89,000 miles on her. She's running full synthetic now (not that it would change my issue) and now I'm hearing very distinct valve tapping, but not ALL the time. I hear it well at idle (most of the time) and it appears to go away as the engine revs and on the road. It is also sometimes absent at idle, but when it's there, it's obvious.

Any ideas? :confused
 

·
Prepping for the Ebola Zombie Apocalypse
Joined
·
62 Posts
Discussion Starter #2
Oh yeah, I do run premium in her too. Here in Louisiana that's 93 octane. It's done this through the last three tanks of gas. No, the oil light doesn't flash.
 

·
Premium Member
Joined
·
16,594 Posts
First how mechanical are you, will you be doing the work?You should first read the sticky I posted at the top of this section and head gasket and valve train noise. Then do an oil pressure test.
If you want help with this, send me your number and I'll walk you thru it.
 

·
Prepping for the Ebola Zombie Apocalypse
Joined
·
62 Posts
Discussion Starter #4
Well, I'm pretty damned mechanical. But I have never performed valve train work. And you have my number, we talked Sunday. :)
 

·
Registered
Joined
·
356 Posts
just the rover tick.. if oil pressure is good then just ignore it!
 

·
Premium Member
Joined
·
16,594 Posts
Well, I'm pretty damned mechanical. But I have never performed valve train work. And you have my number, we talked Sunday. :)
I don't keep numbers. Have you read up on the valve train noise and inspection, if so call me.
 
1 - 7 of 7 Posts
Top