Land Rover and Range Rover Forum banner
1 - 3 of 3 Posts

· Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
Hello Guys ,

This is Kiran from Toronto,Canada . I have bought my Evoque on Aug 2015 and is currently running at 26000 Kms.

Im having an issue with my head lights ,they just wont turn on ..not sure if its a smaller issue with fuse or something big .

Can you guys suggest me what I can do , I'm absolutely dumb coming to cars so I have no idea how to fix it myself .

My car is still in warranty so do you think its going to cover this issue for free ..Also If you can suggest me any good dealer alternative place for regular service and fixing this issue that would be great ..

Thank You...
 

· Registered
Joined
·
1,576 Posts
This is a warranty issue.

You shouldn't have any problem finding a Rover independent in a city like Toronto. Google Rover Repair or European Car Repair. Then, drive past the shops and see how busy they are and stop in and talk to them. If they have a lot full of Rovers, they're probably not bad. You can also check them out with CAA- I'm guessing they have an approved auto repair program in a city of that size. You can look at Yelp, but you've got to take those ratings with a grain of salt. People don't tend to go online unless they have a need to vent. Most pay their money and go away happy.

One of the best ways to judge a shop is in how it's equipped and kept, and what its employees look like. If the place is dark and dirty and the employees look scroungy, keep looking. If they don't care about themselves, they probably don't care about your car. The object isn't to find a deal. The object is to find someone competent. Good and cheap never go together.
 
1 - 3 of 3 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top