Land Rover and Range Rover Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
Hi all,
My RR sport has just had the engine rebuilt after it decided to spin a bearing. The car has been off the road for nearly a year and a half and has cost me a heap to fix. The engine has been completely put back together but is not starting so any help would really really be appreciated as I need it back on the road. Here is some info that might help.

Has done 97,000km
The diesel in it is 1.5 years old but not sure if that could be the problem.
It will only just start but only runs for a couple of seconds (sometimes)
It does start and run on brake cleaner
The main battery has just been replaced but the stop start battery is buggered
Crank sensor seem to be working fine on the snap on scan tool
The car sat in the shed with a flat battery for the whole time it was off the road.
Is making fuel pressure which I think was getting to 30,000kpa when cranking
Ecu has been remapped in the past
There are no codes showing.
Work done by a local workshop (not Landrover)
 

·
Registered
Joined
·
1 Posts
Hi all,
My RR sport has just had the engine rebuilt after it decided to spin a bearing. The car has been off the road for nearly a year and a half and has cost me a heap to fix. The engine has been completely put back together but is not starting so any help would really really be appreciated as I need it back on the road. Here is some info that might help.

Has done 97,000km
The diesel in it is 1.5 years old but not sure if that could be the problem.
It will only just start but only runs for a couple of seconds (sometimes)
It does start and run on brake cleaner
The main battery has just been replaced but the stop start battery is buggered
Crank sensor seem to be working fine on the snap on scan tool
The car sat in the shed with a flat battery for the whole time it was off the road.
Is making fuel pressure which I think was getting to 30,000kpa when cranking
Ecu has been remapped in the past
There are no codes showing.
Work done by a local workshop (not Landrover)
Did you ever get sorted out with this problem?
We have exactly the same problem with a discovery 4 after an engine replacement.
Has us sickened.
 

·
Registered
Joined
·
1 Posts
Did you ever get sorted out with this problem?
We have exactly the same problem with a discovery 4 after an engine replacement.
Has us sickened.
Yeah an injector had failed and the others were gummed up so i replaced 1 injector and got the rest cleaned
 
1 - 3 of 3 Posts
Top