Land Rover and Range Rover Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
20 Posts
Discussion Starter #1
Hello all,

I have a 96 Disco1 SE7 that I just purchased. It has several nagging issues but the one I'm currently looking into is the fact it has very little power and is VERY loud. It sounds like a fan type noise but at 2000 rpm pulling my boat (about 3500 lbs total) I sound like a jet plane taking off and can barely get up a small incline without really putting my foot in it. No check engine/service engine light coming on, it does work when I cycle the key on start up like it should. I'm replacing the fuel filter today and I have premium name brand fuel in the tank.

Also, if any of you are experts in other areas my other issues are:

1. Rear windows inop no power to either switch (center console or door) rear window fuse good and has power.

2. Rear sunroof inop but getting power to both switches.

3. Cruise control inop and yes, I have the main dash switch turned on.

All fuses checked and good. Any help would be great.

Travis
 

·
Rover-Holic and Admin
Joined
·
7,895 Posts
with the engine off see if your fan clutch is seized up. If you can't turn the fan by hand there is your culprit on the noise.
 

·
Support Our Troops
Joined
·
3,667 Posts
3. Cruise control inop and yes, I have the main dash switch turned on.
All fuses checked and good. Any help would be great.
Travis
Have you checked the vac lines for the cruise control? They are known to get cracks in them and that will cause the cruise control to not work. I would look at the lines and replace as needed.
 

·
Rover-Holic and Admin
Joined
·
7,895 Posts
if memory serves a 4.3 chevy fan clutch is a direct swap and half the price.
 

·
Registered
Joined
·
20 Posts
Discussion Starter #6
Army, Thanks for the tip on the 4.3 chevy fan clutch. Picked one up new for 10.00 less than a junk yard Rover one. Had to buy new fan to clutch bolts (2.00) and needed to enlarge the fan holes a little but it works great. Now, I need to move to the other issues. Anyone have any ideas on the rear windows and/or rear sunroof ideas. I will check cruise control vac lines.
 

·
Rover-Holic and Admin
Joined
·
7,895 Posts
I'm no good with window issues I've had a non-working one for 6 years lol.

Glad I could help on the fan issue....
 

·
Registered
Joined
·
20 Posts
Discussion Starter #8
John,

Thanks for the vac line fix. ALL of them were cracked! Replaced and just got back from the test drive and the cruise works great. Replacing the fuel filter improved the power a ton. The one that was on it was very old and restricted something awful. I have noticed a new issue to go along with my rear windows and rear sunroof. My rear subs don't work. Well, to be accurate sound comes out but you have to have your ear right on the speaker cone to hear it. Fade works and the back normal speakers will blow your ears off but nothing from the subs. I pulled the speakers and amp out of the back door and it's getting juice. Any ideas?

Travis
 

·
Rover-Holic and Admin
Joined
·
7,895 Posts
the factory amps suck and I wouldn't be surprised if it was burned up.
 
1 - 9 of 9 Posts
Top