Land Rover and Range Rover Forum banner
1 - 5 of 5 Posts

·
Registered
Joined
·
23 Posts
Discussion Starter · #1 · (Edited)
01 disco ii 4.0 135k...I just repacled head gasket two months ago.Coolant level statyed at normal for a month and havnt checked level till today smelt coolant.And all be damn it was at half way.Where did it go hun!! See no leaking any where checked all obvious places,no milky oil and hose pressure seems normal nice and spongy.Its not overheating coolant temp has been 180 to 200 degress. normal is @ 190.Does this sound right?? I'm going to top it off and bleed system then see how long it takes to drop any help or advice very much appreciated..

Possible Causes

1)Hopefully its just overflow and just need to bleed some air out..

2)Thermostat not opening up due to low running temps causing pressure to overflow.

3)Head gasket leaking but not likely done right to the T.. Took a hour to get to final torque.

4) Slipping sleave hopefully not this truck has never overheated yet.

5) TB heater looks good has been changed before.

All I can think of..

Thanks Again
 

·
Registered
Joined
·
69 Posts
While I know that this sounds obvious, I'd check all of your hoses and clamps. I had a sudden leak recently and I believe that it was the T body hose that was loose. I could smell the coolant and could see the mess but couldn't figure out the source of the leak. My shop found it pretty quickly.
 

·
Registered
Joined
·
202 Posts
Don't fear the worst just yet.

Check for external leaks. If nothing obvious stands out, The best way to do this is to get a bottle of UV dye and a fluorescent black light bulb. Put the dye in the coolant drive around and check with the light.
 
1 - 5 of 5 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top