Land Rover and Range Rover Forum banner
1 - 8 of 8 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
LR3 2007 V8
My heat has not worked on the drivers side but works hot on the passenger. Does anyone know how to fix this?

Notes: The AC works fine on both sides. We manually moved the bland doors to the driver side and still no heat. We are about to replace the heater core.
 

·
Registered
Joined
·
3 Posts
I'm having a similar issue with my 2006 LR3. i will get heat out of the passenger side but not the driver. However, initially i only get luke warm air out of the right passenger vent and the center passenger vent is blowing hot, both blow hot after about 30 min. After the vehicle has been on about 30 to 45 min the left driver-side will blow hot air and the right will be barely warm. The floor vents and windshield vents on the driver side are same as the right driver vent and all on the passenger side blow hot. I have done the self test and it didn't display any errors. From reading previous post there are 2 things it could be (Heater Core, or blend motor/door). I'm leaning towards the Core right now. any thought or suggestions would be helpful before I start the painful process of replacing the core.
 

·
Registered
Joined
·
3 Posts
wouldn't the sensors basically tell the computer to move the motors and open the flaps? i have verified that when the tempter knob is adjusted the flaps move to adjust the amount of air that comes from the heater case. it seems more like there is just not hot air coming from the case.

the HVAC system is not exactly a simple system, but the more i read into it the more it sounds like a Heater core, and that there is a partial build-up/blockage stopping fluid from going into the cell that heats the driver side (US driver side). The blockage doesn't seem to impede the overall flow of fluid in and out of the core, just impedes it from flowing through that side. It's a bit different that what I'm used to seeing, but seems to be a reoccurring theme.
 

·
Registered
Joined
·
2 Posts
I had the driver's side cold issue, a real problem in stormy Tahoe, the heated windshield couldn't keep defrosted by itself, cold toes too.

Dean, the Independent LR tech in Rocklin, CA, popped my heater hoses and filled the core with Calcium Lime Rust Remover[/URL] and let it set for 24hrs, all working as it should now. vipserviceaffordableprice dot com

ps: is there a way to extend the heated windshield timeout?


LR3 2007 V8
My heat has not worked on the drivers side but works hot on the passenger. Does anyone know how to fix this?

Notes: The AC works fine on both sides. We manually moved the bland doors to the driver side and still no heat. We are about to replace the heater core.
 

·
very disco
Joined
·
2,985 Posts
@Rajroverowner
welcome to the forum. if you're quoting this nearly 4yo post because you're encountering the same issue...

it's because the heat exchanger sits lower on the left side (by design) and typically clogs up inside, preventing hot fluid from warming the air on the driver's side via the exchanger. people report mixed success with CLR flushes in their heater core, and replacement of the core is the only sure-fire solution.

if that response isn't helpful, you might start a new post asking a specific question
 
1 - 8 of 8 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top