Land Rover and Range Rover Forum banner
1 - 3 of 3 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
My good friends owns this. it has been raining quite a bit here. he pulls it behind his truck to deer camp, 2 hr drive. this time it rained all the way there. When he arrived and unhooked it would not move. he said battery was low and he had to charge it. He trailer it back. Since then i have installed a new battery. When you put it in gear it feel like something is turning and out of balance in transmission, I pulled the top plug out of tranny. black fluid drained out with small metal flakes. It was driving good before he pulled it down there. My Question is: could the transmission be burnt up?
 

·
Administrator
Joined
·
2,423 Posts
The dead battery part and the m+s lights flashing sounds like a bad alternator (common)
BUT and BIG BUT
From your description your friend flat towed it (wheels turning and on the ground)????
Pretty sure that is a big no no.
Basically turning all the internal workings from the outputs without the aid of lubrication from the pump.
Sounds like it mat be screwed
 

·
certified idiot
Joined
·
694 Posts
redtruck12 x 2
if your friend didn't put the transfer box in neutral when towing the landy flat then parts of the auto transmission (the actual gearbox part) were turning without the pump turning. having the transfer box and axles turn is no big deal but turning the autobox through the transfer case with no pump running will almost certainly toast your autobox.
always tow flat with the transfer box in neutral if you have to tow flat.
 
1 - 3 of 3 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top