Land Rover and Range Rover Forum banner
1 - 8 of 8 Posts

·
Registered
Joined
·
25 Posts
Discussion Starter · #1 ·
OK, so i'm getting Check Engine codes of the following: P0134, P0171, P0304, P1171. This is really pissing me off since I replaced all 4 O2 sensors already. Can a bad MAF cause all of these codes to appear? I'm guessing if your MAF is faulty then the entire thing doesn't work since they are all wired in series. Any input would be greatly appreciated. By the way if anyone is looking for MAFs check out Amazon. I just found one for 33 dollars on there, i'm sure it's not "Genuine" Land Rover "quality" parts but for 33 dollars i'm willing to take my chances. Thanks!
 

·
Registered
Joined
·
380 Posts
I bought one of the cheap ones, didn't work for me sadly, wish it did, I bought one from Autozone w/ a lifetime warranty. Is your MAF coding? I'm not cyphering the codes lol, I had all my o2 sensors show they were faulty then I replaced my mad and the SES went away, not sure if it's still coding or not.
 

·
Premium Member
Joined
·
16,594 Posts
Did you clean the 02 socket prior to installing the new 02's?
Np, this is not MAF related, Bank 1 sensor 1 has failed, just go get it replaced under warranty and all those codes can then be cleared.
 

·
Premium Member
Joined
·
16,594 Posts
Send me your number and lets talk.
 

·
Registered
Joined
·
25 Posts
Discussion Starter · #7 ·
Just got back from Autozone, the O2 sensor killed all of the codes except one. CYLINDER #4 MISFIRE. i've checked the new magnecor wires I just put on there and they are fine, I guess i'll pull the plug and make sure it's got a spark and then the last thing I can figure out is a fuel injector or a coil right?
 

·
Premium Member
Joined
·
16,594 Posts
How did you check them and try switching the #4 plug to another hole to see if the code follows it.
 
1 - 8 of 8 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top